"Could Not Change Administrator Password" WebODM Password Reset

Alright, I feel a bit foolish as I’ve actually asked a very similar question to this before, and got a solution that worked. Unfortunately, I’ve made the same mistake again, and the previous solution no longer seems to work. So here goes.

I tried running a “Factory Reset” on docker yesterday, and after reinstalling webODM through the GitBash command line, when I try to open http://localhost:8000/login/, I’m given an “Invalid Credentials” message. I’ve ran into this problem before, and have been told to run the ./webodm.sh resetadminpassword newpass command. In the past, this has worked and allowed me to Log in with Newpass as my password, but now, I get the following when I input the command to Git Bash


I’m not sure what’s going on here, but if anyone can point me in the right direction I’d be much obliged. Thanks!

1 Like

Have you updated the WebODM code from Git?

Maybe starting completely fresh might be a good place to begin.

Not yet, I’ll give that a go today and see if I have any success.

1 Like

So, I’ve tried resetting WebODM completely per the instructions in this thread

WebODM will launch in gitBash, but I still run into the “Invalid Credentials” message when I try to log into the localhost on Chrome.

Also, when I try to run
./webodm.sh resetadminpassword
I basically see no result whatsoever. This is a screenshot of gitbash several minutes after entering the command.

Am I missing something here? I hoped that doing a hard uninstall would reset everything, password and username included, but that doesn’t seem to be the case.

1 Like

Try executing the resetadminpassword command from another instance of the Git-Bash shell with WebODM started.

Okay, tried that this morning, and it did get the command to execute, but I’m running into the “Could not change administrator password” error again, see screenshot below.

1 Like

Have you tried the rebuild process as of the latest commits today?

If that still fails, I’d recommend removing your WebODM directory entirely, as well as deleting the Docker images and starting fresh. I’m not sure what has happened that you’re getting the errors you are during a reset.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.