Reinstall or reset password

Hi all,

The start script had been launched for days and I could use WebODM without issue.

Today when trying to use it again it failed and I realized the script had crashed without any visible reason. So in the same terminal I just relaunched the start command ([Up], [Enter]) and surprisingly it started downloading things. When WebODM finally started, the layout changed (I modified the logo and theme in the administration menu before, and it looked like it was reset) and my last user name and password are not recognized any-more…

Obviously I tried to reset my password with the ./ resetadminpassword newpass command, but it fails with the following error:

Traceback (most recent call last):
  File "/webodm/", line 22, in <module>
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/", line 381, in execute_from_command_line
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/", line 375, in execute
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/", line 316, in run_from_argv
    self.execute(*args, **cmd_options)
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/", line 353, in execute
    output = self.handle(*args, **options)
  File "/usr/local/lib/python3.9/dist-packages/django/core/management/commands/", line 92, in handle
  File "<string>", line 1, in <module>
  File "/usr/local/lib/python3.9/dist-packages/django/db/models/", line 303, in __getitem__
    return qs._result_cache[0]
IndexError: list index out of range

Then, I also tried the down command and restarting it. I tried removing the local git folder and cloning it again. I tried to update again after download. I tried to use a previous git clone I made a long time ago.

Please, how to solve the situation, that is how to:

  • either totally remove WebODM and restart from scratch the login/password definition
  • or reset the actual password?

Optionally, any idea about why that happened?

Thank you for help,

Best regards,

1 Like

Welcome William!

Sorry you’re having issues.

It likely updated the webodm when you re-invoked it.

Clearing the git folder is part of it, but you’d also have to clear the docker image/container that it creates as well.

Are you familiar with Docker so that you can do that?

Are you familiar with Docker?

Unfortunately… not much :expressionless:


Let’s try this, which should stop anything running, remove it all, grab the latest, and then start it clean.

./ stop
./ down
./ update
./ start

Hi Mr Naib,

First, forgot to thank you for the support.

Then, tried that but situation the same: password not recognized and ./ resetadminpassword command crashing with the same error message.

(However, not surprised, since I played with down/update/start commands all the possible ways before opening the thread…)

OK… so… to hard restart WebODM I just blindly cleared all the docker data on my computer, deleted the cloned git repo and cloned it again like this:

$ # Stop WebODM totally
$ ./ down
$ # Delete the WebODM git repo
$ cd ..
$ rm -r WebODM
$ # WARNING: This totally resets docker on the computer (removes all containers, volumes, everything)
$ docker system prune -a --volumes
$ # Redo WebODM install from scratch
$ git clone --config core.autocrlf=input --depth 1
$ cd WebODM
$ ./ start 

And it finally works…

Fortunately, I did regularly backups of the WebODM results by downloading assets (almost) each time. Else I would have lost everything which had been done so far…

Can understand what happened though.

Best regards,


That was the nuclear option which I was going to suggest next.

Glad you’re sorted and had backups!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.