Unable to display 3D Model on M1 Mac but 2D displays fine

Okay, I am brand new to ODM but trying…

I processed my aerial images (36 jpegs to keep it simple) and it yields a good 2D map, but get blank screen when I try to view 3D Model. Have tried searching the forums for solution. The “Full Extent” button that has worked for some people with this 3D-not-displaying-issue does not fix my issue. I have also tried in both Chrome and Firefox. I am running an M1-chip Mac Mini and using the build designed to work with the Apple-chipped (M1) Macs. My 2D display and ODM Quality Report pdf does show what appears to be a fairly accurate Digital Surface Model, so I think the 3D data is in there somewhere(?) Any help is appreciated. Thanks!
p.s. Since I am a “new user” I could only put one attachment jpeg on this post.

2 Likes

Welcome!

Sorry for the trouble. This is a new one…

Could you please provide any further details about your Mac including MacOS release, and the versions of Safari, Chrome, and Firefox you tried?

Mac Mini M1, 2020
Mac OS 12.1 Monterey
Chrome Version 98.0.4758.102 (Official Build) (arm64)
Firefox 97.0.1 (64-bit)
Safari Version 15.2 (17612.3.6.1.6)

1 Like

I have a similar system (OS 12.2.1, M1 Max MacBook Pro 2021) and I have been able to view 3d models in WebODM in the past though my workflow has changed to use the command line and QGIS. I am willing to recreate your situation – can you tell me what you’re clicking after the model generation is complete?

1 Like

Here is a quick example using the default settings on a dataset I had handy. All I did was import the images, click the button to start the job, then click the View 3D Model button.

I’m running Safari Version 15.3 (17612.4.9.1.8) for what it’s worth.

Oh! I updated WebODM before starting the job – it’s now at version WebODM 1.9.11!

1 Like

Great point.

Are you running the latest update to WebODM?

Success! Last time I had submitted my project photos via a Lightning page (I think that was it, at least). But since they showed up on my Web ODM page, I figured I did what I was supposed to do (especially after I was able to get the 2D image). This time I did (on Safari) directly in the Web ODM dashboard interface and it went through, processed, and displayed the 3D model perfectly!
BTW, Yes, I am running the 1.9.11 version.
Thanks for everyone’s help!

2 Likes

Did you submit the job via the Lightning Dashboard:

If so, it doesn’t enforce the --pc-ept flag, which is required to view a 3D model in the WebODM interface via PoTree.
image

Uploads via the program will, however, enforce the --pc-ept flag.

what sort of images are you guys able to process over a mac m1 chip? what the largest dataset that it can handle?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.