Processing results - 3D Model

Hi everyone!

I’m fairly new to WebODM, but have been running as many different datasets as I can to get better and explore the functionality.

It is possible to notice that the models of the houses (simple constructions) are rounded and imperfect.

To compare, I ran the processing in dronedeploy and the result is much more realistic.

What could I be doing wrong. The images of a dataset are in the links belows (dronedb and google drive).

All drone images, taken with a Mavic Air, both at nadir and oblique with DD (with 3D enhanced feature)

I’ve already run different settings (Default, High resolution, and others customized from comments in this community).

Even the orthomosaic is far poor.

Could you help me understand what I’m doing wrong? Thanks so much



Dronedeploy 3D

1 Like

What’s your settings?

1 Like

Hi Andreas,

That’s the latest settings:

Criado em: 11/02/2022 15:09:35
Nó de processamento: node-odm-1 (auto)
Opções: auto-boundary: true, dsm: true, pc-quality: high, dem-resolution: 2.0, orthophoto-resolution: 2.0
Average GSD: 1,26 cm
Área: 2.672,07 m²

Reconstructed Points: 3.138.237

1 Like

Try increasing mesh-outree-depth and mesh-size, that might help a bit.


Welcome, Henrique!

Looks like your GSD is closer to 1.25cm/px, so you should lower the cap for --orthophoto-resolution and --dem-resolution to 1.26 or below to get optimum output quality there.

As for the buildings, you could try increasing the --pc-quality to ultra, along with increasing --feature-quality to ultra. You may also see improved realism of building construction with --pc-geometric enabled.


I really appreciated your comments.

I used this setting and the results are incredibly better, but some rounded corners and imperfections insist on continuing.

Options: dem-resolution: 1, dsm: true, feature-quality: ultra, orthophoto-resolution: 1, pc-geometric: true, pc-quality: ultra, rerun-from: dataset

Can anything else be done in the settings to improve the mockup of the house or just more photos (with new positions) improve the details?



1 Like

Well mesh-octree-depth will help a bit

1 Like

Can you post your Report PDF? It might help us tune with you better.

Also, try Andreas’ suggestion, but be warned that it is incredibly heavy on RAM, so you may not be successful in increasing it much (try increasing by +1 at a time).

1 Like

Try to increasing min-num-features, the default is 8000 which is low enough. Try to change it to 12000 (If your computer is powerfull enough, change it to 16000). Mesh octree depth is usefull for increasing verticles but the cost of increasing (drastically) RAM.

**Options:** dem-resolution: 1, dsm: true, feature-quality: ultra, orthophoto-resolution: 1, pc-geometric: true, pc-quality: ultra, rerun-from: dataset, mesh-octree-depth: 12, min-num-features: 12000

Additional note : WebODM tends to delete faces if there are no suitable texture to fit that faces. If you add texturing-keep-unseen-faces, the hole will be filled by white faces.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.