Orthophoto .kml/kmz extension file download in WebODM

I’ve selected this option while processing my images.

  1. How the option works as it doesn’t produce any separate file with .kmz extension for google earth?
  2. And how can I get the .KMZ file for google earth in WebODM for visualizing orthophotos?

Can you please provide your processing options and full processing log?

I’m having difficulty reproducing the inability to generate a KMZ here locally.
image

Screenshot (122)

As you can see, I’m using the Orthophoto:true option. But still the .KMZ file is not available in assets. I also checked in downloadable Zip file.

I think there is some source code changes, to enable this option in my native Windows WebODM.

How Can I provide you full processing log?
INFO.pdf (689.5 KB)

Is this what you want?

1 Like

Try to update WebODM (the latest version is 1.9.7).

1 Like

Thanks For the suggestion!
I really appreciate the changes in updates.
But it didn’t really solved the problem for me this time too.
I updated the version as mentioned through software update option available and it also got updated successfully.
I processed new set of images to check, if file is generated or not. This time also same result as before. I’m here attaching screenshot for your reference.
Screenshot (123)

And also logs too.

INFO.pdf (523.9 KB)

Is the KMZ there if you download the All Assets (all.zip) file?

No. I downloaded the zip file too. Only .png and .tif files are there in orthophoto folder and no .kmz in any other place.

Are you able to share those ten images? I can’t reproduce not being able to get a KMZ output.

Yes Sure!
I’m sharing the link of DroneDB as you suggested me before for sharing datasets.
The link contains 10 sample images what I want to process. please let me know if you need more or anything else.
And In processing option I just want DSM, DTM and a good 3D point cloud. So you’re free to use any options to try on these samples.

farm - DroneDB

1 Like

Thanks for the sample data.

image

Worked fine locally:
image

Options: cog: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 1, dsm: true, dtm: true, matcher-neighbors: 16, mesh-size: 300000, min-num-features: 16000, orthophoto-kmz: true, orthophoto-resolution: 1, pc-classify: true, pc-ept: true, pc-filter: 1, pc-geometric: true, pc-quality: high, use-3dmesh: true, verbose: true

Have you done a complete uninstall, manual removal of the directory where it was installed, and then re-install? You’re not working with your customized build, are you?

yes, I even changed the device and installed the software there for first time.
The results are same. Look if some changes in code to enable the function.

I’m sharing the results again that I got in my device.

Screenshot (2)

Screenshot (1)

All I did same as you, but still didn’t get the results or .kmz file in assets.

And I’m not working with customized build. I’ve purchased the Windows Native Installer. And using the same on my Windows 10.

INFO.pdf (364.1 KB)

1 Like

If you go to D:\WebODM\resources\app\apps\NodeODM\data\3821e303-292f-4eec-add1- 670b3da787b8\odm_orthophoto\ are you able to see the KMZ?

The log shows that it should be created correctly.

Very strange indeed.

1 Like

Yes Sir, It’s there.
Screenshot (3)

I even checked it on Google Earth. It doesn’t show any overlap with ortho-photo but it is in exactly correct cordinates.
Yes, strange indeed. There something wrong with UI and backend connection or processing of .kmz file.
Even if it is there, it is not useful yet.
Screenshot (4)

image
It is working in Google Earth Pro Desktop.

I believe the browser version is still pre-release and experimental.

ohk Got it. But still it doesn’t solve the problem of not getting .kmz file on WebODM UI or web instance.
Can you please find the bug or whatever it is. is it some Desktop mode or multiple user option?

Could you open an issue on Issues · OpenDroneMap/WebODM · GitHub so that we can track this?

Also mandatory link to read: How To Request Features — OpenDroneMap 2.6.3 documentation

1 Like