Latitude Longitude Elev ... or ... Longitude Latitude Elev. which is it?

GCP Editor Pro, offers “example files” … in Northing, Easting, Elev(ft) or Northing, Easting, Elev(m) or Latitude, Longitude, Elev(m) … no examples appear available.

GCP Editor Pro, an aerial(Google?), shows aerials in Wisconsin, I simply zoom out into my area, and use as is to set up the GCP’s.

I load my photos and mark control, save then download, but the order is now saved as Longitude before Latitude and every project that worked out before now crashes or looks like modern art.

I’m sorry you are having problems. I use GCP Editor Pro as a stand alone program. I find in very functional and easy to use.

To enter your control via a txt file (GCP_Label, Lat,Long, and Elev in meters). Browse to the control file, select the file, select the correct EPSG code or PROJ string for the correct datum of your control. You can look these up in QGIS or at epsg.io.

You will see a list of your control points. Hit the Go to next step button. You should see your control plotted on the google maps photo base along with a list of GCP’s with a Tag button next to each one. Pick the photo that show GCP and mark the image of the control point. Be careful you only mark the GCP you are working with. Extraneous marks will produce bad GCP’s . If you confuse or mis-mark the GCP you will get “modern art”.

After all your photos are marked, hit the go to next step button. You will see the text of your gcp_list.txt file. It should show the EPSG code or PROJ string in the first line. It is formatted as thus: x( long), y (lat), z, image x,image y, filename (image), GCP label.

This gcp_file.txt file should be downloaded to the same directory as your photos. It should run fine. Check out the report GCP section for clues to see which points might be mis-marked or incorrectly entered.

Best of luck - it took me several times to be successful.

M

2 Likes

My Long/Lat is -DD.ddddd DD.ddddd NaN XXXX.xxxx YYYY.yyyy file name(case sensitive(?) gcp01
I manually checked all my photos’ coordinates associated with gcp01 … all are very close

I chose to use the defaulted “NaN”, for elevation, but I wondering about case sensitivity for the file, if this is an issue(case sensitive), that also involves the suffix(file type), my old drone saved in *.jpg, this new drones saves in *JPG, but the case is held from the drone file to the job file.

I save drone photos to a working file(personal), and to this folder, I add the space delimited GCP file. All the used photos & GCP file is then selected into the project and is successfully stored.

I may have used a single photo for more than one GCP(without a separate loading), and will work to ensure not to do this.

I also have access to some very precise and rather accurate sid files for the county. These files are much more accurate(?), than Google and I’ve checked many thousands of various points, which left me quite astounded … the Long/Lat often disagrees with Google by 5-10 feet in places.

EPSG:4326
-81.1310267 41.0989197 NaN 1732.9398 292.69869046157083 20230118_153500_0214.JPG gcp01
-81.1310267 41.0989197 NaN 1736.3387 651.94981269567640 20230118_153504_0215.JPG gcp01
-81.1310267 41.0989197 NaN 1749.0803 1166.7961720749981 20230118_153506_0216.JPG gcp01
-81.1310267 41.0989197 NaN 1766.2993 1736.2103579794220 20230118_153508_0217.JPG gcp01
-81.1310267 41.0989197 NaN 2451.8088 455.47474330085770 20230118_153442_0211.JPG gcp01
-81.1310267 41.0989197 NaN 2447.3223 1069.0626986162665 20230118_153444_0212.JPG gcp01
-81.1310267 41.0989197 NaN 2443.5841 1652.0653856865442 20230118_153446_0213.JPG gcp01
-81.1300455 41.0996832 NaN 1152.0850 393.20227927389850 20230118_152543_0004.JPG gcp03
-81.1300455 41.0996832 NaN 1175.6725 797.68193274064950 20230118_152546_0005.JPG gcp03
-81.1300455 41.0996832 NaN 1194.7164 1236.3978522681557 20230118_152548_0006.JPG gcp03
-81.1300455 41.0996832 NaN 1416.7631 1487.5811793880820 20230118_152854_0070.JPG gcp03
-81.1300455 41.0996832 NaN 1371.7929 2023.3986220775416 20230118_152856_0071.JPG gcp03
-81.1294115 41.0994020 NaN 3149.9611 612.35635238971020 20230118_152535_0001.JPG gcp02
-81.1294115 41.0994020 NaN 3157.1128 845.31247415274600 20230118_152539_0002.JPG gcp02
-81.1294115 41.0994020 NaN 3186.3236 1195.2827255147813 20230118_152541_0003.JPG gcp02
-81.1294115 41.0994020 NaN 3211.7151 1583.4774425844942 20230118_152543_0004.JPG gcp02
-81.1294115 41.0994020 NaN 3232.4409 1981.5463543300448 20230118_152546_0005.JPG gcp02

Thanks
John

I never used NaN for elevation. So I’m not sure about it’s case. The case of the image name and extension needs to match and be identical in the gcp file. Beware spaces and parentheses in the gcp file. They cause problems.

I had inadvertantly marked extra gcp’s in the wrong location. Just make sure you only have one gcp marked per photo

1 Like

Please try substituting NaN for 0 if you are having a failure to process with the GCP file.

2 Likes

I never used NaN for elevation. So I’m not sure about it’s case. The case of the image name and extension needs to match and be identical in the gcp file. Beware spaces and parentheses in the gcp file. They cause problems.

Spaces … the simple “space” …is this the witchcraft that has been vexing me?

To be specific, an extra space in the image file name has caused me problems.

The gcp_list file, as output, is a tab delimited .txt file

1 Like

Oh … “tab”, delimited … my worse nightmare … even hated them on typewriters …

Does this also mean the “*txt” is actually a rich text file?

EVIDENTLY, my spreadsheet does not appear to have a tab-delimited option for save as or export.

I don’t understand this back and forth of space, comma, then tabs, or Nan and 0

I should also ask, if photo 1, shows a tire(A), target(B), and a fence corner(C), and I use the tire as a GCP, that if in photo 21, all three of the items in photo 1 are visible, can I, or not, use one of these items(B or C on photo 1), as a GCP, or must I be removed enough that anything I mark on photo 21 or 57 or 124, cannot include any item that shows up in photo 1?

You don’t need to worry about this as it is all standard output of GCP_Pro.

Sorry for the bad quote in my previous post. You don’t need to worry about the tabs as they are the standard output of gcp_list.txt file of GCP_Pro.

The file is just a standard vanilla text file. No rich text. Once again you don’t need to worry about that, just use the gcp_list.txt file that GCP_Pro outputs.

Ok, my point is when you tag each target for the seperate control points, be careful, if you accidently click elswhere in the photo ( not on the target) it will accidently place your gcp in the wong position. I alway zoom into the pixel level and mark. Take one last look at all the tagged images to insure correct mark placement. I also paint control point numbers nearby for easy identification. Otherwise the control marks all look the same at the pixel level.

You can have several control points in the same image, but you tag them seperately. Mind you, its a good idea to have your control spread evenly over the job, but sometimes they are on the same image, and thats ok.

M

FANTASTIC!

The control, are indeed space delimited, and it doesn’t seem to matter how many spaces the only point that “moved”, seems to be a mailbox that was displaced at the edge of the photos, while the base map was pretty much overhead(displaced to the base of the post).

Now, to make full use of GCP Editor Pro, I need to know if it can work with *.sid files … or other options, otherwise I have to go into a sid reading program to manually obtain my data in DDD.MM.SS.sss, then convert to DDD.dddddd …

We do not support loading MrSID basemaps nor layers. QGIS on Windows can have support for it, however, if you need a good desktop GIS Suite to work within.

1 Like

Well, without, at least L1 GPS, accurate coordinates are not available from google. I have access to very accurate coordinates in a more convoluted manner. I would be nice to use this data in the editor.

Speaking of the editor I worked a set of GCP’s, but when I load them, my first GCP is highlighted(Bold), then disappears when I access the map.

I have tried it as *csv and *.txt both ways same problem. I also tried placing a "EPSG:4326 header(just to see…), no go …

GCP01,41.098902,-81.131012,1141.8 (this GCP keeps disappearing
GCP02,41.099387,-81.129701,1150.5
GCP04,41.100333,-81.129750,1161
GCP05,41.100014,-81.130550,1157.5
GCP09,41.102295,-81.130014,1189
GCP12,41.099408,-81.133970,1191
GCP14,41.100847,-81.131215,1176

The example file has a header line that will be consumed when loaded and act as the column labels. Please ensure when you make the files by hand that you adhere to the example files’ structure exactly.

What is happening is that you do not have a valid header line, so the program is using your first GCP as the column header.

1 Like

MrSID is, last I checked, a patented format that is then licensed under a library that is incompatible with free and open source software. There are packages, such as versions of QGIS, that support MrSID. Perhaps they even support export to other formats to improve your workflow. They used to, so hopefully they still do.

Sadly, we have no control over the ownership and licensing of proprietary formats that we don’t own. I suppose the one upside is the same ownership protections help protect projects like OpenDroneMap.

The truly frustrating part is often publicly acquired aerial imagery datasets get locked into these proprietary formats, datasets that are otherwise critical data infrastructure.

1 Like

I have looked everywhere for the example file “gps-template-latlon.csv”, I have done complete searches of my C: drive and my WebODM dedicated D: drive. For that matter, I cannot even find GCP Editor Pro, program per the target address “C:\Users\User\AppData\Local\Programs\GCP Editor Pro\GCP Editor Pro.exe”
Where can I get a copy of these examples? It would be nice to make full use of the editor from start to finish … I can always “Adjust”, the coordinates later, by any means necessary …

1 Like

They are available in the GUI of GCP Editor Pro to the right-hand of the screen (on a normal size monitor/window, otherwise they’ll reflow like in the screenshot below). You can expand the block of text entitled “Download CSV Examples” and click on one of the links to download them. Similarly, the other block “CSV format specification” details the required format of the GCP list.

1 Like