Firewalls and port settings

I am trying to share links for specific tasks that are on this PC. I have read all of the posts on here about port forwarding, opening port 8000, and maybe 20, and 22, and 443 (sigh) but nothing will connect. I have opened the same ports in Windows Defender as well.
Is there some easy to follow setup for this? Is Docker using a different port ?
My end game will be to load another instance of WebODM on another computer on my network and only allow external access to that computer. But I want to make sure I have it working first.

1 Like

I’d check out this comment and general thread for quick note on networking.

Remember that WebODM is mostly just the interface to make task creation easy. There is a NodeODM instance running under the hood to do the actual work.

I would try this:

  1. On your primary computer, run WebODM.
  2. On your second computer, run an instance of NodeODM like
    docker run -p 3000:3000 opendronemap/nodeodm
  3. Back on the primary computer, try to add this new node to WebODM under
    WebODM > Processing Nodes > Add New
    Use the IP of your second machine and port 3000. WebODM will then display the status of the new processing node.

If I am understanding the question properly, you do not need to run WebODM twice (once on each machine). Someone else will have to comment on port availability.

2 Likes

I will flag this info with thanks.
But in the mean time I am just working on getting the thing visible.

1 Like

I want to do all of my processing on my main machine, with no external exposure to the internet. Once I’ve processed a project, I want to download the “all Assets” zip file and transfer that to the secondary machine running webodm. And that will be the machine exposed to the internet, and I would supply links to clients to those projects/tasks.
But first my struggle is getting any version of Webodm visible to the outside world.

Ah I misunderstood “sharing” in this context. Yes, you’d have to run WebODM on a server with a public IP.

It’s still in beta, but I’d check out DroneDB and click on “Hub”.

3 Likes

I notice that the IP address in the sharing link (192.168.99.100:8000) is not an IP that my router recognizes, and not the IP of the machine webodm is running in.
I believe it’s the IP that VM is using.
Do I have to change some setting in Virtual Box to make webodm visible ?
I have been tinkering with port forwarding setting in virtual box but still nuthin.