Error Invalid imageDimensions parameter upon uploading images using webodm

End Goal: I have some TIF files that I wanted to create a slippy map.

I used the cloudodm client with webodm Lightning but I receive an error “Invalid imageDimensions parameter” when running the webodm client. From googling, my hunch that this maybe related to an imagemagick error but the jpegs return nothing abnormal when I run identify on each of them.

What I did:
(I use Ubuntu 16.04)
convert the TIF into jpeg because odm doesn’t support TIF yet,
using imagemagick;
ran:
for i in ls *.tif; do convert $i $i.jpeg; done
(I also manually renamed the files here so they were just filename.jpeg instead of filename.tif.jpeg)

Version: ImageMagick 6.8.9-9 Q16 x86_64 2019-06-15
Copyright: Copyright © 1999-2014 ImageMagick Studio LLC
Features: DPC Modules OpenMP
Delegates: bzlib cairo djvu fftw fontconfig freetype jbig jng jpeg lcms lqr ltdl lzma openexr pangocairo png rsvg tiff wmf x xml zlib

Then I used Webodm’s gcpi to create ground control reference points of them.

Then downloaded the gcp_file.txt and the 1.0.0. release of cloudodm (x86-64, linux binary) from github

then ran odm
myusername@kayar:~/prg/odm$ odm -d -v -f ~/geo/1969-aerial/files ~/geo/1969-aerial/gcp_file_1564076173057.txt
Loaded configuration from /home/myusername/.odm.json
Input Files (5)
* /home/myusername/geo/1969-aerial/files/14-124.jpeg
* /home/myusername/geo/1969-aerial/files/14-125.jpeg
* /home/myusername/geo/1969-aerial/files/14-127.jpeg
* /home/myusername/geo/1969-aerial/files/15-104.jpeg
* /home/myusername/geo/1969-aerial/gcp_file_1564076173057.txt
Options:
GET: the-webodm.net/info?token=my-token (url redacted)
NodeODM version: 1.5.3
GET: the-webodm.net/options?token=my-token (url redacted)
[gcp_file_1564076173057.txt] 11.98 MiB / 11.98 MiB [=========================================================================================================================================] 100.00%Invalid imageDimensions parameter

to download the files:
copy the image url below: https://f002.backblazeb2.com/file/publique/2019-webodm-debugging/14-124.jpeg (this is one of my images) for the rest of them;
replace 14-124 with 14-125, 14-127, and 15-104.

if anyone comes across this; I didn’t solve this yet; I thought it may be because my images are grayscale. I found this example from Minnesota used ODM to stitch together historical aerial imagery. I examined the source images and they were grayscale but they were in the RGB colorspace, so I thought, maybe I should covert my images to the SRGB colorspace.

so I tried that using imagemagick (same version as before; convert is one tool within the imagemagick suite): for i inls *.tif; do convert $i -colorspace sRGB $i.jpeg; done; which should have converted them to the RGB colorspace, but I used identify again, the photos’ colorspace was still reported as gray in imagemagick. I had the same results again too when uploading them through cloudodm.

I’m deciding to try this again in the native odm client to see if I can obtain more verbose results.

(Update: I decided to use the odm client instead, and my findings are at Unable to convert scaled value (1e+32) to int32 (PDAL) (with grayscale colorspace images)

1 Like