Error: cannot import name Transformer

File “/code/run.py”, line 12, in
from stages.odm_app import ODMApp
File “/code/stages/odm_app.py”, line 4, in
from opendm import types
File “/code/opendm/types.py”, line 8, in
from opendm import location
File “/code/opendm/location.py”, line 3, in
from pyproj import Proj, Transformer, CRS
ImportError: cannot import name Transformer

Code 1 had tried to re install, Native install on Fresh Ubantu 16.04
ran scriot to install everything. All went well and started WEBODM.

when processing first set get code 1 error, tried on several missions

Does running:

pip install -U pyproj

Fix the problem?

will try that and update.
thanks

1 Like

as stevechris wrote above i have the same problem on a fresh ubuntu 16.04, webODM from installer script.

tried: pip install -U pyproj

So after that i get the following log errors:

Traceback (most recent call last):
File “/code/run.py”, line 12, in
from stages.odm_app import ODMApp
File “/code/stages/odm_app.py”, line 10, in
from run_opensfm import ODMOpenSfMStage
File “/code/stages/run_opensfm.py”, line 11, in
from opendm.osfm import OSFMContext
File “/code/opendm/osfm.py”, line 13, in
from opensfm.large import tools
File “/code/SuperBuild/src/opensfm/opensfm/large/tools.py”, line 7, in
import psutil
ImportError:
No module named psutil

So then i did: sudo pip install psutil

AND IT WORKED.

1 Like

Thanks for sharing your solution @laurynas.oo!

glad worked for laurtnas.oo however i am still getting code 1 error
ImportError: cannot import name Transformer

What is the output of?

pip freeze | grep pyproj

and

python --version

@stevechris?

python version 2.7.12
pyproj==1.9.5.1

If you run:

sudo pip install -U pyproj==2.2.2

Does the problem go away?

Ran that says could not find a version that satisfies the requirements pyproj==2.2.2

All right, how about:

sudo pip install -U pyproj==2.2.0

Or

sudo pip install -U pyproj

?

`sudo pip install -U pyproj==2.2.0

that did it, processing now.
thanks for your help.

1 Like