Cannot Process Dataset - Processing stopped because of strange values in the reconstruction

I tried running WebODM’s Orthophoto stitching using a custom option I saw in this link. I have 302 images to be stitched in which the environment is a forest/vegetation area. However, when I tried to stitch my images using the custom settings I made, WebODM stated that it cannot process the dataset after running for 1 hour and 29 minutes.

This is the custom option I set: boundary: {“type”:“FeatureCollection”,“features”:[{“type”:“Feature”,“geometry”:{“type”:“Polygon”,“coordinates”:[[[125.6533914252065,7.375402748240649,0],[125.6533597528796,7.374369825442982,0],[125.659406254218,7.374132868658386,0],[125.6594501291116,7.375152468343286,0],[125.6533914252065,7.375402748240649,0]]]},“properties”:{“name”:“DIFCO 3”,“tessellate”:true}}]}, dem-resolution: 1, dsm: true, feature-quality: ultra, mesh-octree-depth: 12, mesh-size: 1000000, optimize-disk-space: true, pc-quality: ultra, split: 100, split-overlap: 75, tiles: true, use-3dmesh: true

My WebODM is in Windows 10 running in Hyper-V Virtual Machine with 24 CPUs, 57GB RAM, and 32 GB Swap allocated in my Docker. My WebODM version is 2.0.1 and my Docker Desktop version is in, and my Docker Engine version is in 19.03.8.

Here is the link to the full log



Sorry for the trouble, and thanks for the great details! Super helpful.

Have you attempted giving this dataset a processing pass at full Defaults to ensure it can reconstruct okay before we start turning quality dials up?

1 Like

Hello Saijin. Yes, I was successful in running it in both default settings and fast orthophoto settings but the output orthoimage quality is not that good that is why I used a custom setting - in which it stated that it cannot process the dataset. I also tried to preprocess the images using XnConvert for enhance and contrast but it still did not work.

1 Like

You likely are running out of RAM, then.

Try raising orthophoto-resolution only at first.