Any Kroscloud users?

I’m looking for a way to share the textured models online.
I see that can be done through 3dviewer.net, but for larger models, it never seems to finish loading.

Someone suggested I try https://www.kroscloud.com/ but that needs .glb files - which WebODM doesn’t output.

Does anyone here know a good way to either export .glb files or convert the textured model (obj) to a .glb file? I found an online converter but it tells me my model is too big.

Check out DroneDB: https://dronedb.app/ (disclaimer: I’m one of the authors)

You can just upload your OBJ files and it will create a streamable mesh for viewing.

Example model: Hub

2 Likes

Hey. Thanks. And no problem - if you’re putting in the work then you should get a little credit :slight_smile:

I had taken a look at that before but didn’t see how to upload the model to view it. I’ll be honest, I didn’t spend a lot of time looking at it, so I should try again, but if you have a quick tutorial on how to do that lying around that would be great!

Thanks

I tried to do this but I think I’m missing something.
I upload all the OBJ model and all of the JPG files into a folder. When I click on the obj file - or right click and say open 3d model, it opens the screen I get if I click on your Hub link, but then it says Not Found at the top bar

Also, for some reason, it keeps doubling the number of files.

Uh, strange. Can you share a link to it?

Does this work?
https://hub.dronedb.app/r/houldsworth1/3d-model-example

1 Like

It seems you’re missing a file (the .mtl file). That needs to be uploaded too. The model should show up shortly after you upload the corresponding .mtl file.

OK. Now it is working but…the results are not very good.
Here is a screenshot from WebODM

And here is a screenshot from DroneDB

If I did something wrong (which is very possible) please let me know. And if you want any files to help diagnose the problem, let me know that too.
Thanks!! If we can get this working this would be a great solution.

@pierotofy
Did you get a chance to take a look at the differences in how the model is shown?

I’d love to be able to help get DroneDB to the point where it matches the view in WebODM directly, so if I can help with any data, etc. please let me know.

Thanks!

I did and I can confirm that the model looks strange. For some reason it’s not loading the proper level of detail when zooming in.

This will require further troubleshooting, as I’m unsure of the cause (and it’s the first time I’ve seen it).

OK - much appreciated. If I can help with anything, please let me know.

I’ve opened Some 3D models do not load properly · Issue #82 · DroneDB/Hub · GitHub to keep track of this.

Thanks. I’m not really a Github user - but I’ll join and follow along.

Hi.
I ran another test yesterday and uploaded it - this one seems to work fine, so I can only assume that somehow I messed up the previous upload.
You can see the new one here: Hub

I tried re-uploading the previous model but without luck - not sure why that is giving such trouble but it might be the model and not the DroneDB software - seems likely.

1 Like