Why I have the issue of " Child returned 137"

this is issue picture

docker run -it --rm \

-v $(pwd)/images:/code/images \
-v $(pwd)/odm_orthophoto:/code/odm_orthophoto \opendronemap/opendronemap

I use docker
picture counts:224
dimensions: 4000 x 3000
I want to know why I have this issue?

Note the Killed text in the error message. That means you ran out of memory!

Try resizing your images, or if you just need an orthophoto, try to use the --fast-orthophoto parameter.

I ran with the same problem as follow:

2019-09-23 17:39:31,638 INFO: Shots and/or GCPs are well-conditionned. Using naive 3D-3D alignment.
Traceback (most recent call last):
File “/code/run.py”, line 57, in
File “/code/stages/odm_app.py”, line 92, in execute
File “/code/opendm/types.py”, line 370, in run
File “/code/opendm/types.py”, line 370, in run
File “/code/opendm/types.py”, line 370, in run
File “/code/opendm/types.py”, line 351, in run
self.process(self.args, outputs)
File “/code/stages/run_opensfm.py”, line 29, in process
File “/code/opendm/osfm.py”, line 39, in reconstruct
File “/code/opendm/osfm.py”, line 21, in run
(context.opensfm_path, command, self.opensfm_project_path))
File “/code/opendm/system.py”, line 76, in run
raise Exception(“Child returned {}”.format(retcode))
Exception: Child returned 137

Where do I type “–fast-orthophotoparameter” altogether?

How are you currently running OpenDroneMap? Are you running it from WebODM?

Terminal on my macbook and docker.
Memory: 8 gb 1600 MHz DDR3

Ooh, 8gb is small. You might consider using the flag --max-concurrency 2 or similar to reduce memory usage.

Flags can be added after the docker image name, e.g.:

docker run -it --rm \
    -v "$(pwd)/images:/code/images" \
    -v "$(pwd)/odm_orthophoto:/code/odm_orthophoto" \
    -v "$(pwd)/odm_texturing:/code/odm_texturing" \
    opendronemap/odm --fast-orthophoto 

Or alternatively:

docker run -it --rm \
    -v "$(pwd)/images:/code/images" \
    -v "$(pwd)/odm_orthophoto:/code/odm_orthophoto" \
    -v "$(pwd)/odm_texturing:/code/odm_texturing" \
    opendronemap/odm --fast-orthophoto --max-concurrency 2

edit: no disrespect meant to your macbook. 8GB is fine for most tasks, it’s just relatively small for photogrammetry.

1 Like

Ohh, I see. Actually it is very fast for my daily tasks, by the way.

So, is it shutting down because of my low memory?

I thought it could take a little longer, but shutting down, I did not know it.

I need to understand better those tricks.

I am a beginner in the coding.

I will try those codes here.

Thanks for the quick answering.

1 Like

Yes, my laptop has the same memory.

Yes, Killed is usually a sign of an out of memory error. Good luck!

You can also use webodm.net if you are running out of memory (disclaimer: I run that service).