Where is requested GSD obtained?

It doesn’t appear to be from the options:

Options: auto-boundary: true, feature-quality: ultra, mesh-octree-depth: 13, mesh-size: 600000, min-num-features: 15000, optimize-disk-space: true, orthophoto-resolution: 0.01, pc-quality: ultra, use-3dmesh: true


[WARNING] Cannot calculate GSD, using requested resolution of 5.00

44 phone camera images of a fungus, no GPS

Amazingly it is using practically all of 96 GB RAM (actually 95, but Chrome also running), PLUS close to 200GB virtual memory!

Also, it appears to be stuck here after 1h15m:

Found material0105
Loading odm_textured_model_geo_material0105_map_Kd.png

I’ve leave it another hour before killing the task

EDIT, it’s still going after nearly 2.5 hours, but this appears to be why it is going so slowly for such a small area:

Model area : 361.969m2
Model resolution, width x height : 177575x203842

Virtual memory is getting a serious workout!

The actual area is well under 1m^2.

1 Like

We have defaults set as fallback, and they come from a few places.

One is the config.yaml, another is point_cloud.py. The logic for the fallback is in gsd.py

1 Like

But why was my requested resolution ignored? I input 0.01cm, which is pretty close to actual.

1 Like

Here is the result of my first run of the task, a roadside puffball:

I’ll try not setting the Ortho resolution next time

1 Like

You need to use ignore-gsd so it will use the exact resolution you specified. Else it will be capped by the calculated gsd.

1 Like

I ran it again leaving it at the default 5cm, and it completed in only 45min vs 3h12m.
The reported area was still hundreds of times larger than actual.

1 Like

It occurs to me that it may have something to do with a wrong focal ratio in the camera model.

Maybe you can figure out the correct value (you need the focal length and sensor width) and write a custom camera_models_overrides.json file (Providing your own camera parameters - OpenSfm).


I’ve signed the CLA upstream, so if they are still taking PRs I can submit it there as well.

1 Like