When trying to install pdal for webodm, I get pdal-config not found

#1

pdal 1.6 is installed but trying to install pdal through pip generates the error of pdal-config not found. the reason i went back to do this manually is because i ran the paid installer and it complained about not finding an install of pdal, even though pdal --version outputs 1.6

0 Likes

#2

PDAL is included in the ODM build. You shouldn’t need to install it separately. Something must have gone wrong during the build process?

cd /code
sudo bash configure.sh reinstall
0 Likes

#3

By careful watching of that command, i see a few tracebacks that cause errors due to failure to resolve some hostnames. The script just moves on as if there are no errors, shouldn’t it retry the operation until it resolves the hostname? I’m behind community internet and for whatever reason it sometimes takes multiple tries to get name resolution.

0 Likes

#4

Here’s the error I was referring to @pierotofy

—code—
CMake Error at modules/odm_georef/CMakeLists.txt:30 (find_package):
Could not find a package configuration file provided by “PDAL” with any of
the following names:

PDALConfig.cmake
pdal-config.cmake

Add the installation prefix of “PDAL” to CMAKE_PREFIX_PATH or set
“PDAL_DIR” to a directory containing one of the above files. If “PDAL”
provides a separate development package or SDK, be sure it has been
installed.

– Configuring incomplete, errors occurred!
See also “/code/build/CMakeFiles/CMakeOutput.log”.
See also “/code/build/CMakeFiles/CMakeError.log”.
Configuration Finished

—/code—

0 Likes

#5

I’m not entirely sure why that error is showing up. But I would recommend to remove any other version of PDAL installed on the system. Can you confirm that you are on Ubuntu 16.04?

0 Likes

#6

I ran the native installer on a fresh VM of Ubuntu 16 and I still spotted the error before it was buried in the console but PDAL doesn’t install. My 30 days is up.

0 Likes

#7

I will look into it.

0 Likes