What are the correct way to set node's max concurrency and max images?

I’ve seen people mention using --max_concurrency and --max_images when starting a node, but when I try I just get “unknown flag: --max_images” and “unknown flag: --max_concurrency” errors.

$ docker run -dp 3001:3000 --runtime=nvidia --env NVIDIA_VISIBLE_DEVICES=0 --max_concurrency 20 --max_images 4000 --name nodeodmgpu01 opendronemap/nodeodm:gpu
unknown flag: --max_concurrency

What am I doing wrong here?

1 Like

Shouldn’t you use split?

I’m using split in the task settings, and these settings are to dimension the nodes in a cluster.
I found that (as others have discussed) in a cluster the split threshold is interpreted liberally. E.g. in my last test with ~7300 images and split=2000 it actually allocated ~7200 images to the first node in the cluster and ~2500 images to the second node, which effectively nullified the benefit of having the additional node.

1 Like

Have you tried lovering the split value?


docker run -dp 3001:3000 --runtime=nvidia --env NVIDIA_VISIBLE_DEVICES=0 --name nodeodmgpu01 opendronemap/nodeodm:gpu --max_concurrency 20 --max_images 4000 
1 Like

Thanks Piero, that works!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.