WedODM Install Fails on MacOSX

I am attempting to install WebODM on my iMac Pro … MacOSX 12.6.1 and am running into a dilemma.

I have docker desktop running fine and have installed GitHub.

I have checked to make sure my environment does have virtualization support.

From the terminal I executed the following commands

$ git clone GitHub - OpenDroneMap/WebODM: User-friendly, commercial-grade software for processing aerial imagery. 🛩
$ cd WebODM
$ ./ start

It seems to start OK with the following output.

Checking for docker… OK
Checking for docker-compose… OK
Starting WebODM…
Using the following environment:

Host: localhost
Port: 8000
Media directory: appmedia
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1

Make sure to issue a ./ down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1

unknown shorthand flag: ‘f’ in -f

See ‘docker --help’.

So it’s complaining about the -f flag in the docker command line.

Any suggestions what I’m missing here?

Thanks so much.

1 Like

What version of Docker are you using?

Docker Engine is 20.10.21.

1 Like

I am in the exact same boat. Have you figured out a workaround for this?

1 Like

No solution yet … although I’ve been in daily contact with the WebODM Manager people. They have a number of people with the same issue and I’m confident they’ll come up with something soon.

1 Like

I found a solution just minutes ago!
In Docker click on Preferences > General > (scroll to the bottom) and uncheck “Use Docker Compose V2”

Apply and restart. Quit Docker and relaunch. It’s working for me now!


1 Like

Your solution seems to have worked for me as well.
Thanks for sharing.


Worked for me too! Thanks.

1 Like

Thanks everyone for finding this!

This is a highly temporary work-around since docker-compose v1 is deprecated and will be disabled at some point (and we use docker-compose v2 everywhere else), so we’re looking into exactly what is happening on some machines to hit this issue.

To that end, could you please provide me with the following information:

  1. Full Output of WebODM Manager console.

  2. Output of the command in MacOS Terminal: which docker-compose

If you’re feeling adventuresome, you can try running the following command from the MacOS Terminal, closing WebODM Manager, re-opening it, and trying it again to see if it behaves now with the docker-compose v2 option enabled:

pip3 install docker-compose

Docker 4.14.1 is out and now works fine with WebODM and Docker Compose v2.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.