WebODM won't start : Starting webapp ... error

I’d installed WebODM around January and had used for a very very brief while. Had successfully managed to set it up on my system with help from @pierotofy here. I’d installed it using Docker Toolbox since I’ve got Windows 10 Home.

Now I haven’t used it since then. I tried running it today, but it won’t start up. Here’s the error I’m getting after I try to start the script.

Error checking TLS connection: Error checking and/or regenerating the certs: There was an error validating certificates for host "": dial tcp connectex: No connection could be made because the target machine actively refused it.
You can attempt to regenerate them using 'docker-machine regenerate-certs [name]'.
Be advised that this will trigger a Docker daemon restart which might stop running containers.

                        ##         .
                  ## ## ##        ==
               ## ## ## ## ##    ===
           /"""""""""""""""""\___/ ===
      ~~~ {~~ ~~~~ ~~~ ~~~~ ~~~ ~ /  ===- ~~~
           \______ o           __/
             \    \         __/

docker is configured to use the default machine with IP
For help getting started, check out the docs at https://docs.docker.com

Start interactive shell

[email protected] MINGW64 ~
$ cd WebODM/

[email protected] MINGW64 ~/WebODM (master)
$ ./webodm.sh start
Checking for docker...   OK
Checking for git...   OK
Checking for python...   OK
Checking for pip...   OK
Checking for docker-compose...   OK
Starting WebODM...

Using the following environment:
Host: localhost
Port: 8000
Media directory: appmedia
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Make sure to issue a ./webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml start || docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up
Starting db         ...
Starting node-odm-1 ...
Starting webapp     ... error

ERROR: for db  (2, 'WaitNamedPipe', 'The system cannot find the file specified.')

ERROR: for node-odm-1  (2, 'WaitNamedPipe', 'The system cannot find the file specified.')
ERROR: Windows named pipe error: The system cannot find the file specified. (code: 2)
ERROR: Windows named pipe error: The system cannot find the file specified. (code: 2)

[email protected] MINGW64 ~/WebODM (master)

I found this here Issues · OpenDroneMap/WebODM · GitHub

However, this isn’t working either and is giving me an error.

I would like to start afresh and would also like to update to version 0.4.
What would be the best way to go about this?
Would I have to remove everything and start over including Docker?


Has this been resolved? I am having the same issue and have reinstalled both Docker and Virtualbox at least five times and am still getting the same error.