WebODM wont start - Docker for Win 10 Pro

Having issues getting WebODM to run on a new install. I was previously using Docker Toolbox but have recently upgraded to Windows 10 Pro so have installed Docker for Windows.

I have been using the Windows Powershell for the commands. Cloned the repo ok and cd’d into the WebODM folder but when it came to ./webodm.sh start the command window flashed up and then disappeared with nothing further happening. Tried running in the command prompt but get a random error saying ‘.’ is not recognised as an internal or external command, operable program or batch file. Have tried running Powershell and command prompt as admin but no change in operation.

From there, I tried docker ps and it of course shows no containers running.

Docker settings (see screenshot)
Shared C drive
2 x cpu
4096mb memory
2048mb swap
64gb image size

Any help much appreciated.

Hi. I´m having the exact same problem. Did you ever manage to figure out a solution?

I was never able to figure out what the problem was and ended up cleaning the previous install and using Docker Toolbox instead. At least I can use WebODM now.

1 Like