WebODM (Windows Native) 2.0.1 Update

I know a few people have been inquiring about this. The latest update for Windows native is now available :partying_face:

10 Likes

:tada: :partying_face: :tada:

4 Likes

Oh, sweet!

That path fix is hopefully going to close a few issues.

Time to check :sunglasses:

4 Likes

excellent work,

1 Like

Any cool new stuff?

1 Like

Personally, I’m most excited about the Project and Task Management improvements, but as a whole it’s a great update, especially behind the scenes.

OpenDroneMap/WebODM
v2.0.0

- Expose start_date, end_date in Task API
- Remove Ultra preset
- Cleanup Help Links On Diagnostics Page
- Add ARVI formula
- Better Project and Task Management
- Updated translations
- Login required for GCPI plugin
- Fix dashboard crash when task names are empty
- Project sharing fixes
...
#OpenDroneMap #WebODM #ODMUpdatesBot

https://github.com/OpenDroneMap/WebODM/releases/tag/v2.0.0
2 Likes

Is this what everyone is getting. It’s pretty much useless now. After my projects are done they disappear No option to view only download.

It looks like you are not in the WebODM WebUI, but rather interfacing directly with one of our nodes.

Try interfacing via
https://localhost:8000

This is webODM lighting. I’m getting the same on my server under the IP and port 8000

Do you have the desktop software, or are you using Docker?

I’m unable to reproduce your issue with either installer, or via the Docker version.

I just tried to download it, but got this after a while:
corrupted

1 Like

Please re-download the installer using a download manager.

I eventually managed to download it normally.

Do download managers take over from internally updated app downloads when you don’t actually go to a download page in a browser?

In any case, I allowed node.js access on private networks that windows has blocked for public networks, and clicked to start WebODM, but it failed with this crash, pgsql.log and app.log:

“Booting WebODM 2.0.1 build 88…”
“Trying to connect to NodeODM localhost:29301…”
“nodeodm: info: Authentication using SimpleToken\r\n”
“nodeodm: info: Listening on 0.0.0.0:6367 UDP for progress updates\r\n”
“nodeodm: info: No tasks dump found\r\n”
“nodeodm: info: Checking for orphaned directories to be removed…\r\n”
“nodeodm: info: Server has started on port 29301\r\n”
“Connected to NodeODM 2.2.2”
“redis-server: . \n .-__ ''-._ \n _.- . . ‘’-._ Redis 3.2.100 (00000000/0) 64 bit\n .- .-```. ```\\/ _.,_ ''-._ \n ( ' , .-` | `, ) Running in standalone mode\n |`-._`-...-` __...-.-.|'_.-'| Port: 29379\n | -. ._ / _.-' | PID: 15084\n -._ -._ -./ .-’ .-’ \n |-._-. -.__.-' _.-'_.-'| \n | -.-._ _.-'_.-' | http://redis.io \n -._ -._-..-'.-’ .-’ \n |-._-. -.__.-' _.-'_.-'| \n | -.-._ _.-'_.-' | \n -._ -._-..-‘_.-’ _.-’ \n -._ -..-’ _.-’ \n -._ _.-' \n -..-’ \n\n[15084] 30 Apr 10:25:44.357 # Server started, Redis version 3.2.100\n[15084] 30 Apr 10:25:44.357 * The server is now ready to accept connections on port 29379\n”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 0 failed, retrying…”
“H:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: server starting\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/pg_ctl: exited with code 0”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 1 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 2 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 3 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 4 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 5 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 6 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 7 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 8 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“Attempt 9 failed, retrying…”
“Trying to connect to postgres localhost:29543…”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: psql: FATAL: password authentication failed for user "postgres"\r\n”
“H:\WebODM\resources\app\apps\pgsql/bin/psql: exited with code 2”
{}

and

LOG: could not bind IPv6 socket: Only one usage of each socket address (protocol/network address/port) is normally permitted.

HINT: Is another postmaster already running on port 29543? If not, wait a few seconds and retry.
LOG: could not bind IPv4 socket: Only one usage of each socket address (protocol/network address/port) is normally permitted.

HINT: Is another postmaster already running on port 29543? If not, wait a few seconds and retry.
WARNING: could not create listen socket for “localhost”
FATAL: could not create any TCP/IP sockets
LOG: database system is shut down
LOG: could not bind IPv6 socket: Only one usage of each socket address (protocol/network address/port) is normally permitted.

HINT: Is another postmaster already running on port 29543? If not, wait a few seconds and retry.
LOG: could not bind IPv4 socket: Only one usage of each socket address (protocol/network address/port) is normally permitted.

HINT: Is another postmaster already running on port 29543? If not, wait a few seconds and retry.
WARNING: could not create listen socket for “localhost”
FATAL: could not create any TCP/IP sockets
LOG: database system is shut down


Tried to run it again, but had the same crash.

I’ll reboot the computer to see if that helps.

EDIT - UPDATE: After rebooting, it started and appears to running well, an hour into a task to compare with the previous release.

2 Likes

No, I was not clear, unfortunately. Responding from mobile is apparently not good for me, I apologize.

It would only be helpful if you re-downloaded it from the installer link so the Download manager could take over in the browser.

1 Like

After this stage:
[INFO] Loading odm_textured_model_geo_material0283_map_Kd.png

I have hundreds of lines of this:
2023-04-30 19:20:35,191 WARNING: CPLE_NotSupported in driver JPEG does not support creation option JPEG_QUALITY

Not seen in previous release for the same task.

1 Like

This isn’t indicative of an issue, so I wouldn’t worry about it.

As you noted, this occurs during the generation of the texture maps for the model.

1 Like

Bug report:
when viewing the 3D model with textures, turn on Show Cameras, then turn off Show Cameras and you get a black window. It appears that turning off the cameras turns off the textured model.
Turn off Textured Model and the PC appears, turn textures back on and you again have a black window.
Going back to 2D view, then 3D view, restores the ability to see the textured model.
Behaviour is repeatable.

2 Likes

Could you file this bug in our WebODM tracker?

It’d be good to keep track of.

1 Like

Turning off Show Cameras turns textures off #1642

2 Likes

Great issue!

Piero found and fixed the bug, so thank you!

3 Likes