WebODM stuck on "Pushes complete - joining..."

I am new to WebODM and I attempting to process a 205 image data set from a Phantom 4 (https://www.dropbox.com/sh/h2qes36bn8z6gub/AAACDYbDDEHDu53bJDxCHVbna?dl=0). When it reaches “Pushes complete - joining…”, WebODM stops working. It has been running for around 5 hours now. Some smaller data sets will finish, but not all.

Did you fine tune any parameters? Which ones?
-I used the default parameters.
If applicable, what browser are you using? What operating system? How did you install the software? Be precise.
-Chrome, Windows 10 Pro (64 bit), (12 GB Ram, 256 GB Solid State, and 1TB hard drive) and the software was installed using the WebODM installer.

Does anyone have an idea how to fix the issue. Thank you.

The task output is located with the dataset in dropbox.

Hey @Jeffhathaway07 :hand: I’m guessing you might be running out of memory. Try adding more RAM to docker, or reduce --depthmap-resolution from the task options (or both). https://docs.docker.com/docker-for-windows/#advanced

1 Like

Hello.
I reactivate this thread to mention I ran into the same problem with a ~230 images dataset, neither space nor RAM shortage (Ubuntu 18.04, Firefox, 64Go RAM, 128Go SSD, docker installation, updated on may 1st 2020).

  • I tried twice with a custom set of parameters (orthophoto-resolution: 5.0, dsm: true, pc-csv: true, depthmap-resolution: 1000), and got stucked at this “Pushes complete - joining…” step.
  • third time was successful. The differences were a slightly different set of parameters ( orthophoto-resolution: 5.0, dem-resolution: 5.0, ignore-gsd: true, dsm: true, pc-csv: true, depthmap-resolution: 1000), and the --media-dir option to get the assets out of the docker containers.

So it’s OK for me now, but this info might be useful to somebody running into the same problem.

Cheers.
denis

Lack of memory seems to be problematic as a specific cause.

It is also not clear what parameters in the above post might have contributed to the issue.

These stuck jobs don’t respond to being deleted or cancelled either. However, if the worker is restarted (sometimes it takes a few restarts or at least a delay between stopping and restarting), they can be deleted or cancelled. So this is something to do with the worker container and network/connection issues between webodm and Lightning:

1 Like

Agreed. “pushes complete - joining” is the most common hang point for me, when running benchmark jobs that are too big for my 16GB machine. I can usually cancel and delete the job after a restart.

1 Like