WebODM Storage Space Media Dir Not Working

Hello I use the webodm docker install under linux.
But odm won’t assign and use the defined storage space?

I set the --media-dir at webodm.sh start and it doesn’t work?
Also after that set the volumes in .yml files and it doesn’t work?
Tried webodm.sh update / rebuild / down / start everything… doesn’t work…
Keeps using the storage of the docker volume webodm_appmedia ?!
webodm_appmedia is full…
so I mapped a NAS folder in linux through cifs / smb for this purpose: /home/odm/ODM/data
But why won’t it accept it?
Running out of space and time :wink:

run command:
./webodm.sh start --ssl --hostname example.org --media-dir /home/odm/ODM/data --detached

changed in
docker-compose.yml
under webapp and worker

changed in
docker-compose.nodeodm.yml
under node-odm

changed into this:
volumes:
- “$PWD/ODM/data:/webodm/app/media”

Any help solving this is greatly appreciated.

1 Like

Solved it. Data now seems to get saved to my NAS.
Changed the $PWD/ODM/data into the real full path of the media dir
Also a restart of docker or reboot helped
Made sure the NAS mount was working well
Monitored the usage in Docker of the filesystem
Still not shown the right stats in WebODM Diagnostics though… only shows the docker volume size instead, but guess that ain’t a problem, would be nice though if the defined media storage space and maybe also cpu usage was visible in addition.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.