WebODM stop at night,

Often wile crunching the numbers at night WebODM shuts down and I don’t know why.

Is it WebODM itself or windows that stop it?

I sometimes let it run, go to bed at ten and then in the morning WebODM is not up and running but windows is fine.

What are your windows power and sleep settings

No sleep, alway on.

1 Like

On linux I would just check the uptime of the PC. Maybe it crashed and rebooted. I had that because of faulty RAM. When coming back, the PC was running, but no program was open any more.
Maybe the task manager shows you uptime on windows machines?!

After that I would check docker logs and then WebODM logs.

Strangely it just happens at night, never in the day.

Is this a machine you manage, or is this a work/corporate machine?

My own computer, but it’s happened at work to.

To night it worked though

1 Like

Compare the time that it seems to crash at night with the windows update log, maybe windows did an update and restarted the machine

3 Likes

Didn’t think about updates, maybe they can be set to not do it automatically.

2 Likes

Absolutely. Windows 10/11 have the ability to tune this in the Windows Update Settings and advanced options.

2 Likes

Found that I can pause the updates for while.

2 Likes

I personally don’t like that as you can miss critical out of band security updates and fixes, but rather recommend you tune your Active Hours.

It would be best if it asked before doing anything.

1 Like

That is a setting you can tune in there as well :slight_smile:

If you read the Event Logs, you should be able to see why it shut down. It may not be Windows at all. Could be a thermal event :person_shrugging:

Thermal is very good, no issues there

1 Like

Hi, I had the same problem on my laptop pc.
My pc never stop while webODM processing all night after running “awake” setting of PowerToys from microsoft.
Hope it will help.

3 Likes