WebODM space shown not corresponding to Docker image size

WebODM 1.3.6
Server 2019
Docker Desktop

My projects have stopped processing and my webodm diagnostic page say my space is full - Free: 0 bytes | Used: 58.4 GB | Total: 58.4 GB

My docker settings are currently set to 400GB - Disk image size:
400 GB (54.8 GB used)

I’ve tried increasing my docker image size, to try force webodm to refresh it’s reported size, but it made no difference.

I’ve tried backing up my app media and database (using the commands here Moving WebODM to a different computer), then resetting docker to factory settings, creating a new 400GB image and then restoring webodm data, but it still reported as 58.4GB again.

Has anyone seen this before?

Thanks

1 Like

Just reset Docker again, deleted the WebODM folder, created a new Docker image in a new location, pulled the Git repository and ran ./webodm.sh start and setup from fresh… Same thing is happening. Max space is stuck at 58.4GB

Uninstalled Docker, deleted WedODM folder, removed Docker Image folder.
Resinstalled Docker, reinstalled WebODM.
Set Docker to image size to 24GB - BUT WebODM is still showing 58.4

Free: 45.0 GB | Used: 10.4 GB | Total: 58.4 GB

Is this a bug? Why can i not get more than 58.4GB storage and why does it report that much when even Docker is only set to 24GB

Edit: Checked on multiple devices, this is not just a cookie/cache issue reporting old values either.

I’m afraid I can’t help but it might be of use for you to know I too am having issues assigning more storage to WebODM. My setup is likely very different and I have no prior experience in VM’s so I’m learning as I go. I currently have over 100GB assigned to the VM and WebODM shows only 17.8GB available and only 9.5GB free.

It certainly would explain the fits this has been giving me if the storage reported is not changing relative to the VM, although I am not confident that is what is happening in my instance.

When you say VM, do you mean… a Docker container, a VM with a native install, or a VM hosting a Docker container?

It’d be nice to know if a) you’re experiencing what I am or b) I can help

1 Like

If my efforts can assist you I’ll be happy one of us makes progress. But I don’t want to distract from your issue. I planned to start a new thread but I’m trying to understand it a bit better first.

As mentioned, I barely know what I’m doing but I think my situation is a VM hosting a Docker container. I’m using Oracle Virtual Box on Win 10 Home (hurdle I had to get around), Docker Toolbox.

My issue very well could be as simple as I don’t know what I’m doing and have not assigned the disk space appropriately for whatever needs it, the docker container I presume, to see it.

Since I last posted I think I’ve managed to clone the drive I had the Docker container running WebODM, changing format from .vdmk to .vdi I think it was and then was able to edit the drive size and expand it. Fired up the VM using that cloned and expanded drive and no change to the diagnostic page in the web interface to show any more available space.

Sounds like you’ve had a try! Hopefully your issue will be simple to fix, unless it’s the same issue as me.

If you’re running a Windows VM, then just look for the Docker tray icon, right click, settings, resources, then change your image size there.

79050879-e15f2f80-7c24-11ea-96c9-33503a2d3cb6

Your VM disk image size is independent to your Docker image size when it comes to setting it up. If you say you have 100GB assigned to the VM, then that means your virtual Windows environment has a disk size of 100GB, which in turn means your Docker image is likely going to be limited to 60-80GB as the Windows home install is already taking up some of that.

Hopefully that helps?

1 Like

Thanks, I’m afraid my setup is a bit more complex as I had to work around not having Win10Pro so I didn’t get that simple UI to configure from. I believe you have given me the right idea though, I think there is some disconnect between my VM settings and the Docker container.

Everything I read indicates making changes in VirtualBox (My VM program, I can’t use Docker for Windows) should reflect in the docker environment and so far I can’t prove it has not but don’t think it really is. I may have to let Docker set up the default machine again with modified settings I edit into the start.sh file but I’m not happy with that idea yet as I’ll have to start from scratch again. I may need to though.
I am finding some things that may still loop back into your issue.

My WebODM diagnostic says: Free: 9.5 GB | Used: 7.4 GB | Total: 17.8 GB

The total, 17.8GB actually doesn’t seem to make sense for any of it. I don’t really know where that comes from. The Docker environment by default is close to that but still like 19.??GB So I’m not even confident that number reflects the original Docker setup.

Here is something I managed to get on space utilization of WebODM, but it does not have a total available…

Capture2

Also I’m finding references to a WebODM container within Docker, so maybe I’m working on the wrong layer of container, this is all new to me.

Can confirm this happens on my machine too (after resizing the docker storage settings, the container still reports the old size). Restarting WebODM does not help.

I think this is a bug in docker because the Hyper-V hard drive settings still show the old size.

From Hyper-V Manager, right-click “DockerDesktopVM”, go to Edit Disk and match the maximum size to the settings specified in the docker settings (you’ll notice that they are out of sync).

image

image

After Expanding the hard drive, make sure to restart Docker (this is important).

Before:

image

After:

image

If you can confirm that this fixes it, could you add a note in our troubleshooting section @vantageds ? I suspect this might be a common occurrence, until the docker people fix this at least… https://github.com/OpenDroneMap/WebODM/#common-troubleshooting

2 Likes

That worked thanks!
I had no idea Docker created a Hyper V instance when it set everything up, so didn’t even think that was an option to check.

Thanks again!

I’m not sure how to add a note to the troubleshooting part of github though? Do i just fill it as an issue but put Troubleshooting in the title?

1 Like

Just edit the README document (use this link) https://github.com/OpenDroneMap/WebODM/edit/master/README.md by adding a new row in the troubleshooting table. :+1: the click the “Propose File change” button.

3 Likes

Done - Cheers!

3 Likes