WebODM refusing to process dataset without reason given

Hi everyone, I’m brand new to WebODM, as I’m looking for an alternative to Drone Deploy/PIX4D etc which have their own issues.

My problem is getting a dataset processed at all. Using the “default” settings in a new project, it will not get to the end of processing images after uploading. I get a red message stating “cannot process dataset” with no stated reason or error code to work with. Nothing.

I know for a fact these image sets are fine as they work in Drone Deploy AND PIX4D without a hitch.

I am running WebODM on my laptop with the files saved on my hard drive.

Thanks in advance for any help.

1 Like

Just tried the same dataset again and got this different message:

EPERM: operation not permitted, rename ‘D:\WebODM\resources\app\apps\NodeODM\tmp\d1a1b150-9e0c-46e7-ac43-9f8562c224e5’ → ‘D:\WebODM\resources\app\apps\NodeODM\data\d1a1b150-9e0c-46e7-ac43-9f8562c224e5\images’

No idea what to do about this

1 Like

I think this might be a bug, it’s been reported before. I’m not sure what is triggering it; do you have an antivirus installed? If so, are you able to process things if you exclude the D:\WebODM folder from being scanned by the antivirus?

1 Like
1 Like

This time it gave me some information:

[INFO]    Initializing ODM - Sat Jun 19 01:13:18  2021
[INFO]    ==============
[INFO]    build_overviews: False
[INFO]    camera_lens: auto
[INFO]    cameras: {}
[INFO]    cog: False
[INFO]    copy_to: None
[INFO]    crop: 3
[INFO]    debug: False
[INFO]    dem_decimation: 1
[INFO]    dem_euclidean_map: False
[INFO]    dem_gapfill_steps: 3
[INFO]    dem_resolution: 5
[INFO]    depthmap_resolution: 640
[INFO]    dsm: True
[INFO]    dtm: False
[INFO]    end_with: odm_report
[INFO]    fast_orthophoto: False
[INFO]    feature_quality: high
[INFO]    feature_type: sift
[INFO]    force_gps: False
[INFO]    gcp: None
[INFO]    geo: None
[INFO]    gps_accuracy: 10
[INFO]    ignore_gsd: False
[INFO]    matcher_distance: 0
[INFO]    matcher_neighbors: 8
[INFO]    matcher_type: flann
[INFO]    max_concurrency: 8
[INFO]    merge: all
[INFO]    mesh_octree_depth: 11
[INFO]    mesh_size: 200000
[INFO]    min_num_features: 8000
[INFO]    name: d1a1b150-9e0c-46e7-ac43-9f8562c224e5
[INFO]    optimize_disk_space: False
[INFO]    orthophoto_compression: DEFLATE
[INFO]    orthophoto_cutline: False
[INFO]    orthophoto_kmz: False
[INFO]    orthophoto_no_tiled: False
[INFO]    orthophoto_png: False
[INFO]    orthophoto_resolution: 5
[INFO]    pc_classify: False
[INFO]    pc_csv: False
[INFO]    pc_ept: False
[INFO]    pc_filter: 2.5
[INFO]    pc_las: False
[INFO]    pc_quality: medium
[INFO]    pc_rectify: False
[INFO]    pc_sample: 0
[INFO]    pc_tile: False
[INFO]    primary_band: auto
[INFO]    project_path: D:\WebODM\resources\app\apps\NodeODM\data
[INFO]    radiometric_calibration: none
[INFO]    rerun: None
[INFO]    rerun_all: False
[INFO]    rerun_from: ['odm_report']
[INFO]    resize_to: 2048
[INFO]    skip_3dmodel: False
[INFO]    skip_band_alignment: False
[INFO]    skip_report: False
[INFO]    sm_cluster: None
[INFO]    smrf_scalar: 1.25
[INFO]    smrf_slope: 0.15
[INFO]    smrf_threshold: 0.5
[INFO]    smrf_window: 18.0
[INFO]    split: 999999
[INFO]    split_image_groups: None
[INFO]    split_overlap: 150
[INFO]    texturing_data_term: gmi
[INFO]    texturing_keep_unseen_faces: False
[INFO]    texturing_outlier_removal_type: gauss_clamping
[INFO]    texturing_skip_global_seam_leveling: False
[INFO]    texturing_skip_local_seam_leveling: False
[INFO]    texturing_tone_mapping: none
[INFO]    tiles: False
[INFO]    time: False
[INFO]    use_3dmesh: False
[INFO]    use_exif: False
[INFO]    use_fixed_camera_params: False
[INFO]    use_hybrid_bundle_adjustment: False
[INFO]    verbose: False
[INFO]    ==============
[WARNING] Directory d1a1b150-9e0c-46e7-ac43-9f8562c224e5 does not exist. Creating it now.
[INFO]    Running dataset stage
[INFO]    Loading dataset from: D:\WebODM\resources\app\apps\NodeODM\data\d1a1b150-9e0c-46e7-ac43-9f8562c224e5\images
[ERROR]   There are no images in D:\WebODM\resources\app\apps\NodeODM\data\d1a1b150-9e0c-46e7-ac43-9f8562c224e5\images! Make sure that your project path and dataset name is correct. The current is set to: D:\WebODM\resources\app\apps\NodeODM\data\d1a1b150-9e0c-46e7-ac43-9f8562c224e5
1 Like

Are there actually no files in that directory?

Could you screenshot it to show the contents, or copy/paste the output of a dir command on that directory?

Thanks for the reply.

The only two items in the specified folder are “log.txt” and the folder “odm_georeferencing” which is itself empty.

The antivirus will net exclude folders either…

You could try to temporarily disable it as an alternative to adding a folder exclusion.

1 Like

So what do I do about this directory problem? Is there a setting to change?

Were you able to temporarily disable real-time scanning from your anti-virus to see if it was causing the issue for you?

1 Like

Running it again now to see…


Well, my test run worked when McAfee was switched off.

Is this a bug that has some sort of other workaround?

I’m glad it worked eventually. Thanks for your help!

1 Like

Not sure it is a bug on our end. Some AV products are overly aggressive, and it isn’t uncommon for them to cause problems.

You should be able to exclude the entire WebODM directory from McAfee’s real-time scanning to avoid further issues.

Apparently McAfee doesnt allow entire folders to be excluded

Can you exclude the various exe files in it? Not ideal, I know.

You can also consider using Windows Defender, instead.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.