WebODM on Google Cloud instance: DID NOT WORK

Hi All,

I’m new and try to get WebODM work on Ubuntu 18.04 google cloud. I followed what @korn704 posted to set up. The docker image runs in the background And I have created filewall rules for 8000 as in the picture
webodm4

Ping to the machine external ip worked

However, I could not get to the WebODM using http:\myexternalip : 80 or 8000

Could you please help me? I try to test to process my drone images with WebODM.

Thanks!

Alan,

The default installation uses port 8000. So only 8000 should be used in your testing.

Do you have access to port 8000. Do you have an internal firewall maybe blocking your access?

Another option would be changing WebODM to use a more standard port like port 80.

Alan,

If you would like to test with a different port, you can follow this thread:

Thanks.

thanks korn704,

Mine WebODM up and running, the firewall rules needed sometimes to refresh after editing.

Looks cool. I’m now planning for a bigger machine and may test python & api to start instance, upload and process the job then stop instance to save cost.

And in term of cleaning up temp files of WebODM, do you have any idea? Or WebODM should clean it up when we stop the instance?

Thank you very much!
Alan