WebODM Manager will not install on MacBook Air 2022

Continuing the discussion from Unable to install WebODM after purchase:

Today I purchased WebODM Manager for macOS standard and could not install it on a very new MacBook Air (2022), with Apple M2, 8GB, and running macOS Ventura 13.2.

The WebODM Manager Installation Manual only gave instructions for installing WebODM Manager (not Docker separately). I understood that purchasing the Installer Package would allow me to install it much quicker and easier than doing it via the Command Line.

The messages I get after copying WebODM Manager to my Applications folder and trying to install it are that the WebODM manager is damaged and needs to be sent to Trash. I also get a message in Security settings on my MacBook that “Docker was blocked because it wasn’t authenticated and tried to Allow it Anyway.

Under Settings/Privacy & Security on the MacBook, I “Allow” the WebODM software (non-App Store and not an identified developer), but it does not make any difference.

Can anyone help me figure out how to install it? Thank you!!

1 Like

Look at my thread earlier. This was exactly the message I was getting. For whatever reason, the version that WebODM manager tries to install is flagged as damaged.

To fix it, follow the link I posted to the official Docker site. direct URL (Install on Mac | Docker Documentation ) and use that to download Docker stand alone.
Install that and then go back and use the WebODM manager - it will recognize that Docker is already there and work fine after that.

1 Like

So strange…

These are the URLs that the WebODM Manager uses to download docker:

  • https://desktop.docker.com/mac/stable/amd64/Docker.dmg (Intel)
  • https://desktop.docker.com/mac/stable/arm64/Docker.dmg (Apple Silicon)

It might be that stricter safety rules in recent MacOS updates place a quarantine flag on downloaded files? I will run some tests. Sorry for the issues this might have been causing :pray:

1 Like

For notes, this seems to work fine on macOS Monterey (12.5.1, just tested), but I’m betting these issues were introduced with macOS Ventura.

1 Like

Ventura’s GateKeeper is incredibly aggressive, and they’ve changed the verbiage to indicate that the executables are damaged/corrupted (used to say unsigned prior), which isn’t the case.

But yes, even if you download Docker directly from the official website using Safari, you’ll need to contend with GateKeeper for the launch, and then again to install the System Extensions Docker requires to actually run.

There’s also the issue that some machines will not work with Docker releases newer than v4.12, which is seemingly semi-random (mostly Ventura M1 Max machines, but not only and not always).

A key issue is that the automatic installation of docker by WebODM Manager currently does not respect the symlink structure for some of docker’s components (on macOS Ventura) causing the “damaged/corrupted” message. That’s an easy fix, I will have an update soon.

The ability for WebODM Manager to automatically install a third party application (Docker) will probably always require user authorization going forward in macOS Ventura and later, which is an inconvenience, but tolerable.

3 Likes

Ok, the 1.4 update for WebODM Manager is now available (use the same link you used to download previous versions), which should work more smoothly on Ventura. Tested on Apple Silicon Ventura 13.2. Please let us know if further issues persist :pray:

2 Likes

Good morning. I also received separate and helpful replies from Brett Carlock. I tried the installation order/instructions to the letter, but am still having everything ‘hang’ up at the end of the process. Docker will install fine, but WebODM Manager will not. Any thoughts on how to overcome this problem, which I have to assume is because I’m trying to install on a MacBook Air 2022 (Apple M2 chip)? Thank you!

See screen shot attached:

P.S. I followed the most recent advice from pierotofy and barry (with my thanks), but had the same issue. Docker (Silicon chip) installed and opened fine, but WebODM Manager 1.4 did not. See additional screen shot attached.

2 Likes

Thanks for trying and the screenshots, hopefully we’ll get to the bottom of this. :pray:

If you open a Terminal app and type (followed by Enter):

docker --version

Do you get an error message?

Also what’s the output of:

which docker
2 Likes

Yes, the Terminal reply to the first one is: “zsh: command not found: docker”

Reply in Terminal (if that’s what you meant) is: “docker not found”

I have deleted them to try again (when required). Should I reinstall and try the Terminal requests again?

1 Like

When I reinstalled Docker from the link for “Silicon” I got this reply: “Docker version 20.10.17, build 100c701”

1 Like

Something seems to be working now, when I try to install WebODM Manager 1.4. I’ll let you know when it’s done!

1 Like

Success!! I was able to get to New Account set up page and after adding my User Name and Password, I was able to get the New Project page. Thank you for all your help!!

3 Likes

Success!! I was able to get to New Account set up page and after adding my User Name and Password, I’m now at the Welcome screen.

Thank you for all your help!! Now, to get started with some projects!!!

2 Likes

woohoo! We look forward to seeing the projects!

1 Like

Lots to learn, especially using it with my DJI Air 2S, but I started today with a 3D test project. Amazing software that has great potential for future drone subjects. Thank you to everyone for helping me out.

3 Likes

Oh, that’s neat!

Great work!

Well, now I need to know what brand toolbox that is, if known.

Gorgeous model.

2 Likes

It’s an antique (60 years +) ‘Engineers Chest’ that I restored and thought would make a good 3D test subject. Thanks!!