WebODM localhost:8000 not working

==========
IMPORTANT! Having issues processing images?

  1. Search the forum to see if this problem happened to other users.
  2. Check https://github.com/OpenDroneMap/ODM/issues and https://github.com/OpenDroneMap/WebODM/issues for similar problems.

Found nothing? Great, explain in detail the problem, making sure to:

  1. Include a link to your images!

Haven’t made it that far.

  1. Copy/paste the entire task output (not just parts of it) for everyone to read.

"Checking for docker… OK
Checking for git… OK
Checking for docker-compose… OK
Starting WebODM…

Using the following environment:

Host: localhost
Port: 8000
Media directory: appmedia
SSL: NO
SSL key:
SSL certificate:
SSL insecure port redirect: 80
Celery Broker: redis://broker
Default Nodes: 1

Make sure to issue a C:\Users\lostb\WebODM\webodm.sh down if you decide to change the environment.

docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml start || docker-compose -f docker-compose.yml -f docker-compose.nodeodm.yml up --scale node-odm=1
Starting node-odm … failed
Starting broker … failed
Starting db … failed
Starting worker … failed
Starting webapp … failed
No containers to start
Creating network “webodm_default” with the default driver
Creating webodm_node-odm_1 … done
Creating db … done
Creating broker … done
Creating worker … done
Creating webapp … done
Attaching to webodm_node-odm_1, db, broker, worker, webapp
node-odm_1 | info: Authentication using NoTokenRequired
node-odm_1 | info: Listening on 0.0.0.0:6367 UDP for progress updates
node-odm_1 | info: No tasks dump found
node-odm_1 | info: Checking for orphaned directories to be removed…
node-odm_1 | info: Server has started on port 3000
db | FATAL: could not write lock file “postmaster.pid”: No space left on device
broker | 1:C 14 Oct 2019 21:39:09.713 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
broker | 1:C 14 Oct 2019 21:39:09.713 # Redis version=5.0.6, bits=64, commit=00000000, modified=0, pid=1, just started
broker | 1:C 14 Oct 2019 21:39:09.713 # Warning: no config file specified, using the default config. In order to specify a config file use redis-server /path/to/redis.conf
broker | 1:M 14 Oct 2019 21:39:09.718 * Running mode=standalone, port=6379.
broker | 1:M 14 Oct 2019 21:39:09.718 # WARNING: The TCP backlog setting of 511 cannot be enforced because /proc/sys/net/core/somaxconn is set to the lower value of 128.
broker | 1:M 14 Oct 2019 21:39:09.718 # Server initialized
broker | 1:M 14 Oct 2019 21:39:09.718 # WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command ‘echo never > /sys/kernel/mm/transparent_hugepage/enabled’ as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.
broker | 1:M 14 Oct 2019 21:39:09.718 * Ready to accept connections
worker | psql: could not connect to server: Connection refused
worker | Is the server running on host “db” (172.19.0.2) and accepting
worker | TCP/IP connections on port 5432?
worker | Postgres is unavailable - sleeping
worker | psql: could not connect to server: Connection refused
worker | Is the server running on host “db” (172.19.0.2) and accepting
worker | TCP/IP connections on port 5432?
worker | Postgres is unavailable - sleeping
webapp | psql: could not connect to server: Connection refused
webapp | Is the server running on host “db” (172.19.0.2) and accepting
webapp | TCP/IP connections on port 5432?
webapp | Postgres is unavailable - sleeping
db exited with code 1
worker | psql: could not connect to server: Connection refused
worker | Is the server running on host “db” (172.19.0.2) and accepting
worker | TCP/IP connections on port 5432?
worker | Postgres is unavailable - sleeping
db | FATAL: could not write lock file “postmaster.pid”: No space left on device
db exited with code 1
db exited with code 1
db exited with code 1
db exited with code 1
db exited with code 1
db exited with code 1

  1. Did you fine tune any parameters? Which ones?

No

  1. If applicable, what browser are you using? What operating system? How did you install the software? Be precise.

Chrome, MS Windows 10 Pro 64-bit, installed with Docker using PowerShell terminal.

  1. DO NOT address your message to the moderator, a core developer, or any other specific user. The forum is a place where everyone can help answer questions, not just one particular user! Be inclusive of everyone.

Ok

  1. DO NOT reply to a topic that is several months old (unless you are posting the answer to a solution). Open a new topic instead.

Got it.

  1. DO be kind and polite to others.

Will do! Have a great day everyone!

Removed!

So, after some troubleshooting, I have a feeling Docker is the culprit. I was running WebODM this morning when I left the house, around lunchtime, I accessed the computer remotely using TeamViewer, and WebODM was still accessible. When I got home this afternoon, I want to access WebODM, and it was non responsive. I closed the tab, opened a new one, and was unable to load ‘localhost:8000’.

After that I did the following in PS;

  • './webodm.sh stop
  • './webodm.sh start

Didn’t work.

  • './webodm.sh stop
  • './webodm.sh down
  • './webodm.sh update
  • './webodm.sh start

Still no good. So at this point I rebooted the computer since I’ve seen every episode of “The IT Crowd” and that always works.

  • './webodm.sh start

That’s when I get the output posted above. Plus endless;

psql: could not translate host name “db” to address: Name or service not known
Postgres is unavailable - sleeping

Thinking it was an issue with Docker, I checked ran;

  • ‘docker-machine ls’

and got no containers in the list. So, at this point I think there is a reason Docker is either not allowing WebODM to create a container, OR, Docker has an issue with me or my computer. I’m new to Docker, so still learning and learning to troubleshoot.

Any info someone might be able to offer would be great. I have WebODM running on a Google Cloud Compute instance with no issues on Debian, but I like having the local access for managing projects.

Thanks everyone!

Alright, turns out typing it out gives a guy ideas. Here is what I found.

In Docker, it automatically only gave me 60GB for the container disk space. While poking around in the settings page, I noticed that it was 99% full. I have a feeling there wasn’t enough room anymore, and it was failing WebODM.

I increased it to 250GB, and it works perfectly now.

Thanks for the help everyone!

1 Like

ive been having problems … sounds the same as yours …
found the docker settings and increased it …
what happens to those Gb’s do we have to purge them after they fill up ? … and how ?

yup … that works …