WebODM Lightning Times Out On Upload

Hi Folks,
I am trying to test the WebODM Lightning facility, and am having problems uploading files (apologies for such a newbie question, but I am a first-timer).
I have tried this a few times, starting & stopping Docker and WebODM etc…
This is what I have been doing:
On a laptop (Intel Core i7-8700 CPU @ 3.20GHz, Win 10, 32 GB ram, plenty of disk space, Firefox browser)

  1. Start Docker Desktop (Ver 2.1.0.1 (37199), engine: 19.03.1)
  2. Log in to WebODM Lightning via Firefox Quantum 64 bit (ver 68.0.1)
  3. Click on the WebODM button
  4. Start WebODM Manager 1.6.2

In WebODM Dashboard:
5. Click on Lightning Network
6. Add New project
Click on ‘Select images & GCP’ (163 images, average size 11.2 MB)
Click on processing Node - Select Lightning (queue:0) - the only one available
Click on ‘Review’ - (make no changes here… using all defaults)
The ‘Resize Images’ option is selected by default
Click on ‘Start Processing’

It then goes through the ‘Resizing images’ step (OK)
It then starts the ‘Uploading images’ step (I can’t see any console messages other than this ‘Uploading…’)
After about 30 minutes, the job fails, with error:
Connection error: HTTPConnectionPool(host=‘spark1.webodm.net’, port=80): Read timed out. (read timeout=30)

Same thing happens every time I try this operation.
Can you throw any light on this for me, or steer me in a direction to resolve it?

thanks,
Mike

Something on your network might be blocking access to lightning on port 80. What happens if you edit the processing node and change the port to 443 instead?

Thanks Pierotofy,
Given that I am (at this point), completly unfamiliar with WebODM (but look forward to getting to grips with it)…

In my WebODM Dashboard, there were two ‘Lightening’ nodes under options… BOTH had port 80. I changed one of them to 443, as suggested, and tried the Lightening job using that Port 443 via the WebODM Manager.
It looks like it has worked OK.
I’m not sure which port was used for the first job (which failed), but it may have been Port 80.

On a slightly different note…
Before receiving your reply on this forum, I tried the ‘Web Interface’ ((Web UI) button in the Lightning (webodm.net) dashboard.
I used all the defaults, and it took 4 hours to process (this is OK…), but although it produced a series of output files, when I imported the ZIP into WebODM (under Docker), there were NO maps (Ortho or 3D).
This could be because of the default parameters???

This job used the expected number of credits for the number of images, but as mentioned, I cannot see any maps in the file imported to WebODM, so the credits are effectively blown.

I then downloaded all the assets from this job, and when I look at the actual contents of the downloaded ZIP file, BOTH the Ortho and 3D Point Clouds are there.
Using a normal image viewer (outside of WebODM), I can view the ortho tiff, and using 3D Reshaper, I can view the .LAX file… I just can’t see these in the WebODM imported job.

No doubt, the inability to view the imported job in WebODM is down to my own lack of familiarity with the whole process ---- this is something I will get to grips with in the coming weeks/months.

Thanks for your reply to my original note, and if anyone has any thoughts on this note, I would love to hear them!!!

Mike
I know that WebODM is a great tool… I just need to learn how to use it properly.

If you processed the dataset from the WebUI, by default the orthophoto and point cloud tiles (created by checking the “generate 2D and potree point cloud tiles:” option) are not created, so those results cannot be viewed in WebODM (but they can in other programs, as you found out).

Thanks pierotofy…
its good to know that, rather than it being some mistake on my part!
I am learning day-by-day, and loving the software.
Mike

1 Like