WebODM Lightning - Invalid task- task no longer exists


I am running out of time for my project and need some solutions.

Thanks to the community, I discovered my computer is not up to the task of processing my 1800 image dataset, so I purchased 1000 credits on WebODM Lightning.

I downsized and uploaded the images on the WebODM Lighting desktop interface, I was given an estimate of around 800 credits to process it, I have 1150.

I have wasted days uploading images in several attempts just to get the notification each time:

“Invalid taskId: the task no longer exists.”

What does this mean and how do I finally get my map processed? I just don’t have time for more delays.

Please help, thanks.

What is your uplink like? That usually occurs when an upload fails repeatedly or drops due to high latency.

How are you performing the upload? From the WebODM Lightning Manager software for Windows, or via the WebODM Lightning WebUI Dashboard?

Thanks for the response, I ran a quick test:

Latency: 214 ms

Download: 18.37 Mbps

Upload: 16.19 Mbps

I am running it from the WebODM Lightning Manager software for Windows.

Another thought, is there an image limit for the default processing node (Spark1.webodm.net), despite purchasing 1000 credits?


1 Like

Just ran a test again and got:

Latency: 141ms

Download: 50.12Mbps

Upload: 17.24 Mbps

1 Like

Yes. Service Tiers are described here:

1 Like

You mentioned it took you days to upload the task; how many days are we talking about?

Lightning will automatically drop tasks that haven’t finished uploading within 48 hours, assuming that they will not finish.

Have you resized your images? That will significantly lessen the payload to upload a task.


I halved the longest length of the images to save time. The initial upload was quick but it always freezes at about 60% of “uploading to processing node” and stays there until it fails.

Also with credits… it looks like I have purchased them and will have to get a subscription as well, which seems to mean I have paid for 1000 credits for nothing!

If that’s the case do I swap the credits for a subscription (this is a one-off, so a subscription seems to be a waste)?

Get in touch via Contact - UAV4GEO we can certainly refund/swap the credits :+1:


If you’re in a panic Nathan, I can let you use my server to get you out of a hole - it’s sitting idle right now.
Just email me at [email protected] .


Thanks Johnny. I just bought a subscription and tried again. Thanks for your offer but it should be fine


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.