WebODM Lightning hangs after completion

Hey all,

I’ve been running projects in WebODM Lightning and noticed that despite getting an email that my process is complete the Lightning dashboard shows it’s still processing. I can download the files (and they are complete) but in the dashboard it looks as if the project is still running (timer counting up and stuck on “Finalizing all.zip upload this could take a bit…”

The files are ready and downloadable but I’d like to view them in the dashboard. I can’t do this until the dashboard shows the project is complete. (View map shows a map of the world). Is there a way to bring the dashboard back into reality and show the project is complete?


1 Like

It could be a bug; could you attach a copy of the app logs?

1 Like

I’m a pretty new user to all of this but I did go ahead and write it up on the github as well, By app logs do you mean the task output?


1 Like

The app logs are the ones that you get by running:

docker logs webodm_webapp (if you’re using docker)

Or by clicking the ViewApp Logs menu from WebODM Lightning Desktop App (if you’re using that).


Also, if you’re running docker, make sure you are running the latest version! (1.8.2). Older versions had an inefficiency that would frequently cause the program to use too much memory after downloading the results (causing the same issue you reported).

1 Like

Working with Lightning WebODM desktop. Still not sure where to find the logs

Sorry did I say I was new here? lol

1 Like

Ok I found them. Frustratingly not allowing me to upload them due to being a .log file.

Print into a pdf generates 150+ pages?

Here it is

applog.pdf (418.9 KB)


Thanks! This helps.

It looks like the download of the results starts, but never completes. I’ll try to run some tests to see if I can replicate this.

1 Like

Also another question: how is your computer (the one running WebODM Lightning) connected to the internet? WiFi? Would you say your internet connection is pretty stable? How’s the WiFi signal?

Connected using wifi with a stable connection. I work remotely using the wifi on another computer and don’t have any signal issues.


1 Like

Ok, the reason I ask is because I was able to stall the program by dropping my internet connection during download. So if at any point a connection drops, it could lead to the problem you reported.

If you restart WebODM Lightning, does the download complete? Or does it remain stuck?

It remains stuck and actually the timer goes back in time. It was at around 4 hours plus when I quit and when I re-opened it now says 3 hours 18 minutes.


I’ve emailed you a test case that would help a lot to troubleshoot this problem. It might end up in spam because the .zip attachment contains two files (a .py file with contains the script with the test and a .bat file to run it). .bat files usually get flagged as malicious by antivirus/spam software, but you can open them with Notepad and verify they don’t contain anything dangerous.

Nothing yet. [email protected]?

and on queue the process completed…

Yep I used that e-mail. Did it end up in spam?

Got nothing here. definitely j.portolese? sometimes people send it to jportolese

I private messaged you on the forum. That should work.

The theory is that these hangs have been caused by interruption in the download. This could be due to dropped WiFi, a hiccup on the server, or any other connection issue (which are frequent).

PyODM (the library that handles downloads) has been updated to be more stable.

Both WebODM and ODM use now the latest updated library.

WebODM Lightning clients can also be updated by running the latest installer from https://webodm.net

I can’t confirm this is 100% resolved, but I think it should at least make the system more robust.

Key changes: Fix read timeout hanging bug by pierotofy · Pull Request #18 · OpenDroneMap/PyODM · GitHub

Thanks for the report and help!



I am working with WebODM lightning and I found a great tool, since I have no machine resources to run in my computer. There are some observations that I want to share, which I would be very thank with community comments. First, I tried to work with the webpage and the lightning app simultaneously and it is not possible (may be ovious) and it is mandatory to signout in one to access into the other. Since I was having problems to upload from the lightning app, I uploaded the task by the webpage. The results can’t be visualized in the webpage nor in the lightning (since the upload was from the webpage).

  • Can I upload the results into the lightning app in order to visualize the products?
  • Where can I download the Vegetation Indices, since I cannot see them in the results sent from the webpage nor in in the lightning app?

thanks in advance,