WebODM Large Data-set: Process ended with exit code 1


#1

My data-set is 1977 images. Unfortunately, I am unable to attach. this dataset. This is running on WebODM. I’m running this on my windows 10 laptop. Virtual box is set up to use 27gb of my ram, while using 2 of my cpu cores. I was able to make a fast orthophoto just fine. But when I tried doing the default setting, it failed with the below error. I didn’t resize any of the images, as I don’t know what resolution should be set, not if it should be done in WebODM, or through the browser. I would also really like to have a DEM for sink hole analysis. Any recommendations?

Initializing scene with 1977 views…
Initialized 1977 views (max ID is 1976), took 986ms.
Reading Photosynther file (1977 cameras, 1498483 features)…
Automatic input scale: 3
Input embedding: undist-L3
Output embedding: smvs-B3
Running view selection for 1977 views…
done, took 2528.32s.
Resizing input images for 1977 views…
terminate called after throwing an instance of ‘std::bad_alloc’
what(): std::bad_alloc Aborted (core dumped)
Traceback (most recent call last):
File “/code/run.py”, line 47, in <module>
plasm.execute(niter=1)
File “/code/scripts/smvs.py”, line 85, in process
system.run(’%s %s %s’ % (context.smvs_path, ’ '.join(config), tree.smvs))
File “/code/opendm/system.py”, line 34, in run
raise Exception(“Child returned {}”.format(retcode))
Exception :
Child returned 134


#2

terminate called after throwing an instance of ‘std::bad_alloc’

Means you ran out of memory. I’m doubtful 27GB will be sufficient to process those many images, no matter what parameters you tweak.

Either use a computer with more memory or rent one. Also check out https://webodm.net (disclaimer: I run that service).