WebODM fails to obey --media-root flag

Hi all,

I’m just getting started with WebODM and have been struggling to change the directory where WebODM stores uploads & media. I’ve tried changing the MEDIA_ROOT in settings.py but when i run ./webodm.s start it shows that the media directory is “appmedia”, even after a rebuild.

When that didn’t work, I tried this: sudo ./webdom.sh start --media-dir /mnt/odmmedia/media, which is a valid path. That leads to the little environment printout showing the correct directory, but when I try uploading photos the path I specified remains empty and my boot drive fills up.

This is running on Ubunut Server 20.04 with docker version 19.03.8, and following the instructions on the GitHub for “getting started”. Any idea how to make this flag function as described here?

Thanks in advance.


1 Like

Additionally, it now looks like it’s failing to upload images to the default processing node, it just sits here forever.

Any ideas what to check? Thanks.

NodeODM is still mounted at the default location. See Storage Location - Using external source still fills up Docker VHD

We should probably add a flag to map that folder (/var/www/data) from the NodeODM container to a different location…