WebODM Fails at Database Stage

I had just started WebODM up for the first time. It got to the database stage of the installation when it failed. I disabled my firewall and tried again. I was getting the Postgress Authentication error, so I killed off the postgress process and tried again. That error is gone but the system is not starting.


That link contains the screen shot of the error, my OS Version and build as well as the log files.

Thank you

1 Like


I’m seeing a timezone error which can sometimes cause issues.

Are you able to share screenshots of your Date and Time settings via the support email we’ve talked on prior?

Done. I’m seeing install issues using the requirements.txt file so I am working through those as well.

1 Like

When you’re using our installer, there is no need to do anything manually.

The installer got me the original error I posted. If you look in the app log, you can see the manage.py had an error, so I started troubleshooting through that process, noticing that the modules in the requirements.txt file had not been loaded and seeing that C++ was needed for some of them.

1 Like

We run everything in a private virtualenv with a ton of path overrides, so yeah, your system Python would not be aware of anything we ship.

This is by design.

Are you able to undo what you have done thus far?

Yep, not a problem

All cleaned up, and restarted, however the error is still there. Can you be more specific about what you want for the timezone issue please?

1 Like

A screenshot of your Date & Time Settings in Settings in Windows showing your current date/time settings, timezone, automatic sync settings, etc. That entire panel.

If tzlocal is missing your zone, we can have a failure that you caught in the log. I’d like to upstream the timezone definition, if possible.

Sent via the email

1 Like