WebODM crashes if I want to get a high-res orthophoto

Hey Saijin, the images look awesome. I will run the process with the options you recommended. I let you know if I get the same results.

1 Like

Hi, it did not work. I ran it twice (resizing and without resizing).

Created on: 11/24/2021, 8:32:48 AM
Processing Node: node-odm-1 (manual)
Options: auto-boundary: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 0.1, dsm: true, dtm: true, fast-orthophoto: true, feature-quality: ultra, feature-type: orb, matcher-neighbors: 0, matcher-type: bruteforce, mesh-octree-depth: 14, mesh-size: 5000000, min-num-features: 15000, orthophoto-resolution: 0.1, pc-classify: true, pc-filter: 1, pc-geometric: true, pc-quality: ultra, pc-rectify: true, pc-sample: 0.01, resize-to: -1, use-3dmesh: true, verbose: true
1 Like

Did you increase the size of your pagefile?

Another option would be to relax the pc-sample from 0.01m to 0.048m to more closely match the GSD.

Hi, I don’t understand the “increase the size of your pagefile?” part. What I did was to use all the settings you gave me plus activating the “resize images = 2048 px” and it crashed after 6 min. Then, I did the same but without the resize images option. I’ll try the pc-sample option to see what happens. Thanks.

See this guide for how to adjust the size of the pagefile.

How to increase Page File size or Virtual Memory in Windows 10 (thewindowsclub.com)

Keep in mind that you’ll need ample space on the drive for the increased pagefile size.

1 Like

ok I’ll try that option too, although I’m working with a responsive machine.
RAM: 32 GB
Processor: Intel(R) Core™ i7-7700HQ CPU @ 2.80GHz 2.80 GHz
Available space in drive: 200 GB (I have a 5TB external hard drive too)

Just to be clear, when I create a new task using the 19 pics, I do this:
Options: Forest
Edit: All your recommendations
Resize images: No

1 Like

Pagefile has nothing to do with your CPU, it is to address the limitations of the amount of physical RAM you and I both have. 32GB is quite low when you’re looking for high quality outputs, or when you need to push options up to compensate for low overlap/small GSD.

1 Like

I changed the pagefile from a system recommended of 4978 MB to 20000 MB in both my units (c: programs; d: webODM).

I ran the process with the pc-sample from 0.01m to 0.048m, it did not work.

I ran the whole thing again using the option: Forest and without resizing the images and these configuration:

auto-boundary: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 0.1, dsm: true, dtm: true, feature-type: orb, matcher-neighbors: 0, matcher-type: bruteforce, mesh-octree-depth: 14, mesh-size: 500000, min-num-features: 15000, optimize-disk-space: true, orthophoto-resolution: 0.1, pc-classify: true, pc-filter: 1, pc-geometric: true, pc-quality: high, pc-rectify: true, pc-sample: 0.048, rerun-from: odm_postprocess, resize-to: -1, use-3dmesh: true, verbose: true

It did not work.

Should I increase the custom size even more? What pagefile initial size (MB) and max size (MB) do you have?
If this happens with a small pond what might happen with a 5 hectares crop field?

I have attached my settings in this post.

The issue is that we need to crank things up to compensate for low overlap and low feature density.

If subsequent flights have better overlap/sidelap then we can likely relax some options a bit.

1 Like

I followed your 11/23/2021, 3:11:11 PM suggestions. It did not work.
Could you please tell me what pagefile initial size (MB) and max size (MB) do you have?

1 Like

The pagefile settings were in that post, but I’ve re-attached them here:
image

32678MB initial
262144 maximum

I realise Saijin succeeded with ORB, but perhaps try SIFT instead of ORB, as there is not much overlap through the middle of the area, and ORB tends to mostly find features towards the centre of images.

3 Likes

What is the full error message from the task log? Perhaps it’s not a memory issue.

2 Likes

Hi,
Thanks for your suggestions. I still cannot get WebODM to produce high-resolution products.
I ran 3 attempts with the forum suggestions. This is the Google doc with the complete log description:

If it does not work, this is the summary of each test:

Test 1 (00:15:59)

Processing Node: node-odm-1 (manual)
Options: auto-boundary: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 0.1, dsm: true, dtm: true, feature-quality: ultra, feature-type: orb, matcher-neighbors: 0, matcher-type: bruteforce, mesh-octree-depth: 14, mesh-size: 5000000, min-num-features: 15000, orthophoto-resolution: 0.1, pc-classify: true, pc-filter: 1, pc-geometric: true, pc-quality: ultra, pc-rectify: true, pc-sample: 0.01, resize-to: -1, use-3dmesh: true, verbose: true

Test 2 (00:00:17)

Processing Node: node-odm-1 (manual)
Options: auto-boundary: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 0.1, dsm: true, dtm: true, feature-quality: ultra, matcher-neighbors: 0, matcher-type: bruteforce, mesh-octree-depth: 14, mesh-size: 5000000, min-num-features: 15000, orthophoto-resolution: 0.1, pc-classify: true, pc-filter: 1, pc-geometric: true, pc-quality: ultra, pc-rectify: true, pc-sample: 0.048, resize-to: -1, use-3dmesh: true, verbose: true, rerun-from: odm_postprocess

Test 3 (00:00:19)

Processing Node: node-odm-1 (manual)
Options: auto-boundary: true, crop: 0, debug: true, dem-gapfill-steps: 4, dem-resolution: 0.1, dsm: true, dtm: true, matcher-neighbors: 0, matcher-type: bruteforce, mesh-octree-depth: 14, mesh-size: 5000000, min-num-features: 15000, orthophoto-resolution: 0.1, pc-classify: true, pc-filter: 1, pc-geometric: true, pc-quality: high, pc-rectify: true, pc-sample: 0.048, rerun-from: odm_postprocess, resize-to: -1, use-3dmesh: true, verbose: true

Thanks.

Thanks, my brain was burned and I missed that. I followed that suggestion too. I ran 3 attempts and it did not work. I published the Google doc with all the details.

I had to do the presentation to my supervisors using low resolution products (fast orthophoto). This works ( Options: crop: 0, fast-orthophoto: true) but it is not good enough for research level purposes.

1 Like

You’re running out of RAM when fusing the depthmaps.

Try relaxing --feature-quality to high or medium, and I think you should be just fine.

Hi Saijin,
It did not work, it stopped after 4 or 5 hours. I guess I need to test this software in a more powerful machine or in a local network. I will use WebODM to analyze small datasets using my laptop with the fast orthophoto option (<20 pictures, 20MB ea).
I used the lightning mode and I got better results but I understand that I have to pay a fee if I want to process more pictures which sounds fair to me.
I’ll keep trying to find a right configuration so I can use my laptop with WebODM. The software is neat, I need to learn more. Thanks for all your suggestions.

2 Likes

Yes, Lightning requires payment, but I think there is a good mix of pay-as-you-go and repeated billing:

I’m a little surprised that even with the expanded pagefile you’re still not able to process… Our machines are pretty similar.

I’m sorry this has been such a process. Hopefully we can track down what is happening and get you set, but you may be well-served to see if your machine can support more RAM (or indeed if you can use another more powerful machine [at your office?] to do the work).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.