Webodm containers not running in GPU mode

Hi seniors

When I use ./webodm.sh start --gpu I get at most 3/5 of the webodm containers running under container view in docker. At times I get none running. The nodeodm.gpu container never runs.

I am still able to open the webodm ui though. Just after starting to processing, docker always exits. The process will continue to finish. I get “nvidia-smi detected, using GPU for sift extraction” in the process log. I see GPU usage when I run qnvsm.

When I run ./webodm.sh start, I get 5/5 containers running. Docker doesn’t exit and the process proceeds to completion. The most strange thing is that it processes faster than ./webodm.sh start --gpu.

Pc Specs: 64g ram, geforce rtx 3070 VGA, i7 gen11 cpu, Ubuntu 22.04


1 Like

Is everything up to date?

Can you use a utility like topgrade to ensure your system, firmware, docker images, et al are all current?

1 Like

Thank you for your sincere support

I ran topgrade

2nd run

When i run ./webodm.sh start --gpu, i get

It only starts when i add sudo. I still get only 3/5 containers running. the gpu container doesnt run.

Thanks once again.

1 Like

Mmm… Could you please provide me with the output of this command :

id $USER
1 Like

uid=1000(uav04) gid=1000(uav04) groups=1000(uav04),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),109(kvm),122(lpadmin),134(lxd),135(sambashare),138(libvirt),999(docker)

1 Like

Can you try adding your user to the video group, reboot, and try again?

1 Like

Screenshot from 2022-06-24 15-56-55

After adding user,

Also after adding user, when i run nvidia-smi i get:
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running

1 Like

1 Like

These are the log files for each process

GPU.pdf (1.9 MB)
CPU.pdf (3.7 MB)

1 Like

I managed to get 5/5 containers running when I run ./webodm.sh start --gpu.
I replaced docker desktop with docker engine 20.10.17.
Running webodm with --gpu now processes faster than with CPU only.

The problem is that the gpu process is just about 3mins faster than CPU on 1000 images. I need help to fix that.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.