WebODM and Lightning - Not showing results in ODM

Can you copy/paste a screenshot of the “Diagnostic” panel of WebODM?

Thank you.

Here it goes:

Everything looks normal. I really don’t know what could be causing the problem. Does this happen every time, for every dataset or just sometimes?

It happens everytime I process a dataset with Lightning. I’ve tried with three different datasets.

When I process a task locally, using node-odm-1:3000 everything works just fine.

Once you have processed a dataset, if you copy the URL of the dataset from the WebODM Lightning Dashboard (right click it and click “Copy URL”), then can you import it in WebODM via the “Import” button?

Following this discussion with interest, as I have hit this issue overnight too. WebODM is showing the task as still running, but it is completed on Lightning node.

I processed a job a day earlier, and it worked fine. Second job, with same dataset has crashed. First job was just a DSM+DTM and the crashed job was 3D processing.

EDIT: tried importing the completed jobs assets from Lightning and got this error: HTTPSConnectionPool(host='wln1.nyc3.digitaloceanspaces.com', port=443): Read timed out.

EDIT 2: Now getting invalid zip file error. I have contacted the Lightning support team to see what they say.

@pierotofy thanks for the email responses. I managed to download the file as you suggested, directly from Lightning.

However, despite it showing as imported in WebODM, I cannot expand the task at all. The dashboard goes blank:

I have added console output here: https://pastebin.com/Qawnbsui

Do you have enough free space? What does the diagnostic panel show?

I seem to have plenty of disk & memory available:

The weird thing is, if I’m REALLY quick, I can catch the link to the map, and it will open. But I’ve only fluked it once - it’s next to impossible.

Also noted this at tail of console output:

e[31mwebapp        |e[0m   File "/webodm/app/templatetags/settings.py", line 12, in settings_image_url
e[31mwebapp        |e[0m     img_cache = getattr(context['SETTINGS'], image)
e[31mwebapp        |e[0m   File "/usr/local/lib/python3.6/site-packages/django/template/context.py", line 83, in __getitem__
e[31mwebapp        |e[0m     raise KeyError(key)
e[31mwebapp        |e[0m KeyError: 'SETTINGS'

Mm, if you go to Administration – Brand and upload a new “App logo”, does the dashboard reappear?

Well… Here again just to say that after trying several times following some of the indications you posted above, I’m still having the same problem. Even when trying to import, it says that the zip file is “invalid”.

A post was split to a new topic: Docker Issue - Ubuntu 20.04

Hello, I just finished to reprocessing the dataset and the issue continue…

Any idea to solv this problem?

Maybe this screen can help:

Hi everyone,

After several process of the same dataset, I could solve the issue, I think… Basically there is a connection between the min-num-features and the orthophoto-resolution variables.

My theoric dataset GSD is 0.192 cm/px. I could manage to decrese the orthophoto-resolution untill 0.22 cm/px with a min-num-features = 18000. After that the issue continue (never finish and do not show the result).

I hope this help

I’m running WebODM 1.9.10 locally on an AWS Linux 2 box. Browser is Chromium Version 90.0.4430.212. 64GB ram, 500 GB storage. The dashboard display area for tasks goes blank when I select a task to view results or inspect progress. Consequently, can’t show the task execution. The jobs are about 5GB worth of imagery, most of them custom, but just ran a default job with same results.

This problem seems to have been progressive, on the initial run, things worked fine and I was able to download results. Since then, despite restarts of WebODM with and without redirect of the output, behavior is the same, blank display. I’ve rebooted as well. As others have reported, there is a flicker of the task options before going blank.

Any help would be much appreciated!

1 Like

In addition, I’m getting “session data corrupted” errors as well as a couple of missing app logos, app_logo_favicon and app_logo_36, in the process output stream. As I’m clicking on the task menu of the projects.

1 Like

Release 90 is getting on almost a year old.

Are you able to use a current release, or test under a different browser/rendering engine like maybe FireFox?

Just to bring this to closure - ultimately I needed to bring down the entire docker environment and rebuild WebODM which brought me back to normal operation. Many thanks to you for patient instruction!


Observed the missing dashboard behavior tonight after adding the Cesium token and going to the task details (downloads etc). Dashboard flickers and disappears. I disabled the Cesium plugin and voila’ - it reappeared on the next task expansion operation. So, perhaps missing gif’s for the Cesium tiling operation?