WebODM and Lightning - Not showing results in ODM

Hi everyone,

First of all, I want to say that I’m very happy to see this software improving and getting better!

I tried to process a set of photos (DJI Phantom 4 Pro) using the Lightning processing node and my credits. The process seems to run just fine.

When I login to my Lightning account (https://webodm.net/) and I look in my “recent activity”, the task is finished and I can download all the results without trouble. But in the WebODM Dashboard, the task keeps processing and never ends.

I’m using a Linux Mint 19 notebook and running WebODM in Mozilla Firefox. I’ve installed WebODM and all it’s depencies two days ago so I’m using the last version.

Am I doing something wrong?

Captura%20de%20pantalla%20de%202019-07-13%2015-13-46

Hey @Romi-Arg :hand: what version of WebODM are you running? (You can check from the Diagnostic menu). Also, is the console stuck at “Pushes complete - joining…” ?

Hi @pierotofy!
Exactly! It’s stuck at “Pushes complete - joining…”. I attached screenshot but now I see it is a little bit small. Sorry for that.
I’m using version: 1.1.1.

Ok so you have the latest version, good!

How did you install WebODM (and where did you install it, on your local computer, on a server, what operating system, etc.)? What are the specifications of the machine (disk space and memory?)

I’ve installed it on my local computer. I use Linux Mint 19 and I follow the steps described in the GitHub main page of the project (https://www.github.com/OpenDroneMap/WebODM/).

First I installed Docker (I’ve already Python, Pip and Git on my notebook).
Then I followed the steps:
git clone https://github.com/OpenDroneMap/WebODM --config core.autocrlf=input --depth 1
cd WebODM
./webodm.sh start

Afterthat I’ve read that WebODM integrated Micmac so I ran:
./webodm.sh update
./webodm.sh restart --with-micmac

(Micmac appears “offline” on my WebODM Dashboard, but that’s another issue)

Finally, since I want my files on my host filesystem and not in the Docker Volume, I ran:
./webodm.sh restart --media-dir /home/user/webodm_data

I think that’s all. I had no errors during the installation. Actually it was very straightforward and simple.
Any ideas?

Ah! And about my machine:
I have an 256 GB SSD disk + 1T HDD disk (my operating system running on the SSD).
Both disks have 75% of free space (I keep most of my data on external disks)
Memory: 16GB RAM DDR4
CPU: Intel Core i7-6560U

Thank you for the additional info. Could you copy/paste the output of:

docker logs worker

?

Also, does this problem happen sporadically or every time you process a dataset with lightning?

Since I reinstalled WebODM (I haven’t been using it for a while), this is the second task I tried to process. I’ve only tried with Lightning and both times this problem happened. It’s gets stuck at “Pushes complete - joining…”. Should I try processing ir locally?

The output of that command is a bit long and since I’m a new user I can only paste two links. Could I send you the output in another way? A few years ago I asked you a few things about ODM through e-mail. I have those emails and your address. May I send the output to you that way?

Thank you a lot for your help!

You can simply copy/paste it on https://pastebin.com/

I’d rather keep the conversation here, that way we can help users with the same problem in the future!

You could try to process it locally, that might help narrow down if it’s a problem with lightning or WebODM.

Thanks for the pastebin.com tip!

Here it goes:
https://pastebin.com/HQefWTWP

So the problem seems to be caused by a corrupted zip file.

From https://webodm.net/dashboard could you share (even privately) the link to the task assets?

Also, what happens if you restart ./webodm.sh without passing the --media-dir option and try to process a dataset?

Well… I’ve been with some internet troubles and I couldn’t answer until now.

I’m not sure how to share the link to the task assets. However, now I logged in to WedODM and the status of the task has changed.It is still stucked in “Pushes complete - joining…” but now it has no progress bar anymore and it says: “Invalid route for taskId bb096113-09cb-45f3-a02f-06424c75f08d:info, no task table entry”

That’s weird because I didn’t make any changes since my last post here.

I will restart ./webodm.sh without the --media-dir option as you say. In the meanwhile, would you tell me how to share the task?

Hi @pierotofy again!

Some updates:

  • I processed the task again but locally this time (not with Lightning). It worked perfectly even with the --media-dir option. Now I can see all the results and models in WebODM just fine.

  • I tried to proccess the same task with Lightning (without the --media-dir option as I said I would do). I got an “Code 1 error” and the process was cancelled. It didn’t reach that point where it got stucked the first time.

So, definitely my problem is with Lightning not showing results in WebODM. I will try again with a smaller dataset so I don’t run out of credits and let you know what happens.

1 Like

Well, after processing a new task with a smaller dataset in Lightning I’m still having the same problem that I had at the beginning of this post. But this time the console is stuck at “compressing all.zip”. It’s like it went a few steps forward but got stucked anyway.

Just like in my previous attemps, all the products can be downloaded from the Lightning website. The issue seems to be when trying to display the results in WebODM. The task stays processing forever!

Just in case, I ran the docker logs worker comand again and this is the output:
https://pastebin.com/umFR2eDC

Seems like there’s a password in the pastebin. Could you copy/paste it in a public link? :pray:

Oh yes! Sorry. Now it’s public. By default It was setted as “Private”.
https://pastebin.com/umFR2eDC

Hi there again!

I processed a new dataset, larger this time. Same issue with Lightning: all the products are ready since I can download them from the Lightning webpage but in WebODM the task is stucked.

This time it is stucked at:
2019-08-01 00:49:53,100 DEBUG: Robust matching time : 0.000587940216064s
2019-08-01 00:49:53,100 DEBUG: Full matching 226 / 253, time: 3.47596812248s
2019-08-01 00:49:53,699 DEBUG: DJI_0203.jpg - DJI_0229.jpg has 22 candidate matches

Before I started processing this dataset I updated WebODM (./webodm.sh update) and then I restarted it (./webodm.sh restart).

I ran the docker logs worker comand again and this is the output:
https://pastebin.com/J6Z7vXdG

Can you copy/paste a screenshot of the “Diagnostic” panel of WebODM?

Thank you.

Here it goes:

Captura%20de%20pantalla%20de%202019-08-01%2009-28-02

Everything looks normal. I really don’t know what could be causing the problem. Does this happen every time, for every dataset or just sometimes?