WebODM 3D viewer - 3D model is not rendered when enabled

Hey,
I’ve been using webodm via docker and with the direct windows installer for a while now. I ran a very detailed and high poly recunstruction the last few days and I can’t view the resulting 3D modell in the preview window. I can see the point cloud with no issue.

Since I’ve set the poly count to 5 000 000 → is this too much for the built in preview engine?
Playing with the camera modes doesn’t make it visible. I’ve done this before but with a lower quality point cloud and it worked without an issue.

These are the settings I used:
auto-boundary: true, depthmap-resolution: 2048, mesh-size: 5000000, min-num-features: 30000, pc-filter: 0.5, pc-geometric: true, pc-quality: high, resize-to: 4000, use-3dmesh: true, rerun-from: odm_filterpoints
During the feature recognition I disabled the GPU, since it kept failing and enabled it again after 1 day of feature matching :slight_smile: (712 images processed at 4000px)
I’m currently using the latest WebODM windows installer (1.9.15) .

Thanks for the help!


System specs:
AMD 5950X, 128GB DDR 3600MHz Ram, Nvidia RTX3080, Windows 10

I think Potree has a limit on how large of a model it will display. Try exporting your model and viewing it with some other tool, for instance CloudCompare or Blender.

Ah ok. Thanks for the quick answer, I feared having to do that.

This model still looks worse than the point cloud I generated. What could I modify to improve the results?