WebODM 3D Model Quality not as good as Online Site

I have been working with WebODM for a few months now trying to perfect a few things. For the most part I have a good handle on tweaking settings to generate outstanding orthophotos with excellent results. However, I am having a difficult time getting that perfect 3D model. I have uploaded my photos to an online service and they seem to generate a very acceptable 3D model (viewed below and also link to online model) but I cannot seem to replicate their results in WebODM. I know that WebODM has the ability. However, I am just not finding the right combination of settings to get the same acceptable results. I always seem to get a few areas around buildings that have holes in the 3D textured model as illustrated in the attached photos. I was hoping someone on this site may have a solution to my dilemma. The model I am working on is a simple 86 image project that I can provide access to the images in case someone thinks they can overcome the obstacles that I have run into. I would be interested to know if it is just a simple setting that I am just overlooking. Here are the processing parameters in WebODM for the model created so far:
[INFO] build_overviews: False
[INFO] camera_lens: auto
[INFO] cameras: {}
[INFO] crop: 3
[INFO] debug: False
[INFO] dem_decimation: 1
[INFO] dem_euclidean_map: False
[INFO] dem_gapfill_steps: 3
[INFO] dem_resolution: 2.0
[INFO] depthmap_resolution: 1000.0
[INFO] dsm: True
[INFO] dtm: False
[INFO] end_with: odm_orthophoto
[INFO] fast_orthophoto: False
[INFO] force_gps: False
[INFO] gcp: None
[INFO] ignore_gsd: True
[INFO] matcher_distance: 0
[INFO] matcher_neighbors: 8
[INFO] max_concurrency: 10
[INFO] merge: all
[INFO] mesh_octree_depth: 9
[INFO] mesh_point_weight: 4
[INFO] mesh_samples: 1.0
[INFO] mesh_size: 600000
[INFO] min_num_features: 16000
[INFO] mve_confidence: 0.6
[INFO] name: ec8a4a06-2c41-4fca-8570-a52e13b62f0c
[INFO] opensfm_depthmap_method: PATCH_MATCH
[INFO] opensfm_depthmap_min_consistent_views: 3
[INFO] opensfm_depthmap_min_patch_sd: 1
[INFO] orthophoto_compression: DEFLATE
[INFO] orthophoto_cutline: False
[INFO] orthophoto_no_tiled: False
[INFO] orthophoto_resolution: 2.0
[INFO] pc_classify: False
[INFO] pc_csv: False
[INFO] pc_ept: False
[INFO] pc_filter: 2.5
[INFO] pc_las: True
[INFO] pc_sample: 0
[INFO] project_path: /var/www/data
[INFO] rerun: None
[INFO] rerun_all: False
[INFO] rerun_from: [‘opensfm’, ‘mve’, ‘odm_filterpoints’, ‘odm_meshing’, ‘mvs_texturing’, ‘odm_georeferencing’, ‘odm_dem’, ‘odm_orthophoto’]
[INFO] resize_to: 2048
[INFO] skip_3dmodel: False
[INFO] sm_cluster: None
[INFO] smrf_scalar: 1.25
[INFO] smrf_slope: 0.15
[INFO] smrf_threshold: 0.5
[INFO] smrf_window: 18.0
[INFO] split: 999999
[INFO] split_overlap: 150
[INFO] texturing_data_term: gmi
[INFO] texturing_keep_unseen_faces: False
[INFO] texturing_nadir_weight: 16
[INFO] texturing_outlier_removal_type: gauss_clamping
[INFO] texturing_skip_global_seam_leveling: False
[INFO] texturing_skip_hole_filling: False
[INFO] texturing_skip_local_seam_leveling: False
[INFO] texturing_skip_visibility_test: False
[INFO] texturing_tone_mapping: gamma
[INFO] time: False
[INFO] use_3dmesh: True
[INFO] use_exif: False
[INFO] use_fixed_camera_params: False
[INFO] use_hybrid_bundle_adjustment: False
[INFO] use_opensfm_dense: False
[INFO] verbose: False

Here is a link to the 86 images in a DropBox folder:

Image of 3D model results from online site:

Altizure_3D_Model

Here is the link to the the same 3D Model on the online website:

WebODM 3D textured model results image:
WebODM_3DModel_with_Gaps_in_Mesh

Any recommendations would be greatly appreciated. Thank you.

Try increasing mesh_octree_depth (11) and depthmap-resolution (2000), but don’t expect to replicate Altizure’s results. They use different methods to obtain those results.

Also: set camera_lens to brown and you should get very favorable results.

1 Like

Thanks and I appreciate your reply. Between your suggestions (Change lens type to Brown) and Pierotofly’s ( mesh_octree_depth (11) and depthmap-resolution (2000)) the results are getting better but I am still trying to remove those few white gaps then I would be satisfied. Everything else looks great. See below.
WebODM_3DModel_with_Gaps_in_Mesh2

Look at your terms above: it looks like (and these are likely defaults) you are choosing not to fill these spaces. Piero will likely have better tips than I on these, but I would try (in a few iterations):

texturing_data_term: area
texturing_keep_unseen_faces: True
texturing_skip_hole_filling: True

Those gaps are there because no cameras are able to see those parts of the mesh.

You can fill them with texturing_skip_visibility_test, but it’s generally not recommended to turn on that option.

Thank you. I have tried the texturing_keep_unseen_faces: True and that helped a little. I will try the other two suggestions…one at a time… Thank you again!

Thank you. I will try that in my next iteration. Thank you again!