Wavy roof edges in map


#1

Whats up with the wavy edges of these buildings in my map?

What could I try tweaking to solve this?

Thanks!

wavy

Options: min-num-features: 16000, fast-orthophoto: true, orthophoto-resolution: 100, force-ccd: 6.29


#2

Turn off fast-orthophoto and increase mesh-octree-depth to 11 or 12.


#3

Thanks,

Got rid of most of the waves.

Now any hints on how to get rid of the the weird polygon textures and improve the stitching of the building roof?

Options: mesh-octree-depth: 12, min-num-features: 16000, orthophoto-resolution: 100, force-ccd: 6.29

after%20wavy


#4

PS. I like the idea of posting before and after images for future reference in case someone has the same issue and wants to know some things to try to improve the quality. So many parameters, so little knowledge of what they really do in my case…


#5

keep posting comparisons! Its been helpful for my own tweaking.


#6

So here are examples of the same data set processed from Dronedeploy and Autodesk Recap Photo.

Dronedeploy looks great with some weirdness around the dormers on the roof:
droned

Autodesk Recap Photo looks pretty good but had some waves on the roof edges:
autodesk

I feel that WebOdm is likely capable of similar results if I can just find the magic combination of variables.


#7

I’m interested in your recipe if you ever refine it. Pix4D has similar roof edge artifacts where the corners of the roof is round for some reason.


#8

Lower your --mesh-octree-depth and --mesh-solver-divide to 6 or so and see what that gets you.


#9

Here’s what we get for roof lines with low mesh values:

onethirty

:smiley:


#10

Hi,

I tried this answer:

Lower your --mesh-octree-depth and --mesh-solver-divide to 6 or so and see what that gets you.

but still have wavy edges.

Might be because I am on WebODM and do not have “the -mesh-solver-divide” setting available.
Is there a way to change it in webODM without elaborative command line usage (I admittingly have almost no clue about thi, typical enduser :wink: )?

I did lower --mesh-octree-depth to 6 though as its in the menu.

I flew my test mission with a DroneHarmony grid pointing north at 40m height with 70% overlap because I wanted to see the maximum image resolution I could get from the Mavic Air.
Would prefer not to need to go higher.

Only need a high resolution aerial image without 3D model this time.

Thanks,

Franziska


#11

Here some images showing the result and modified settings.
Some funky stuff going on around the trees as well.
Unfortunately the weather was not great, sun low and intense. Was shot around midday though.

WavyImage


#12

WavySettings


#13

Hi @LadyRover, the software has changed a lot since this post. Try now with no parameters.


#14

Thanks, I did more testing today.

Best results with the attached settings. Used the high res preset & added fast ortho and tuned mesh octree down.

Settings%20WebODM%20Aerialshot%20Topdown

Great. Still a bit of funny places visible. Can this be overcome? I use the latest version with docker under win 10 pro.

Any idea when we will see version 2.0 for webODM?


#15

Settings%20WebODM%20Aerialshot%20Topdown%20Result

Still some funky things going on at the Southern Building end (Bottom)…