WARNING Session data corrupted

Following the request from Mr. Pierotify to continue that thread to here WARNING Session data corrupted · Issue #1326 · OpenDroneMap/WebODM · GitHub

As I mentioned before, the error message confuse me.

There is no available Administration > Processing nodes menu

Also checked Processing Nodes > node-odm-1, but I don’t find Object Permissions menu.

The correct one is Processing Nodes > node-odm-1 > edit > Object Permissions.

Accept all permission but problem still exist, problem is not solved

1 Like

The WARNING Session data corrupted notice is a harmless notice from DJANGO and doesn’t really mean anything.

We had silenced that not long ago this year, and I guess we need to do that again.

unfortunatelly, it doesn’t work because WebODM can’t use processing node. It totally unable to process anything. The problem occurs after I updated ODM to the newest one as stated by that github thread

I will try reinstall WebODM from scratch. Hopefully It will solve that problem.

1 Like

Good news
Problem Solved

Here is the way to fix it

# remove all container that ODM has.
>> docker container rm -f  28ff90da39ae 9d83804a33a2 bfaecc7a272a 027e3cdaf0ae 9fcfa257f65d

# remove all images that ODM has
>> docker rmi -f 33e3db53b328 9f35cf88538d 96a8bb742eee e40c0f274bba

# redownload WebODM with github clone
>> git clone https://github.com/OpenDroneMap/WebODM

# install it again
>> cd WebODM
>> ./webodm.sh start --gpu
1 Like

Ah, yeah, sounds like your installation got corrupted somehow.

By the way, I’ve silenced that warning from DJANGO so you won’t see it again (at least until the next time they change their log classes :stuck_out_tongue: )


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.