Volume measurement- Invalid Task Output

Hey everyone, Phil here. I am very new to this software, actually was recommended by a friend. I’ve ran into a problem which I assume will be a simple fix but due to my lack of knowledge I am out of my depth. I will try to explain it to the best of my ability but if more info is required you might have to walk me through what you are looking for. I tried searching the forum before posting and couldn’t seem to find the exact problem I’m having.

I flew some stockpiles of dirt with my DJI Inspire 2 with x4s camera. I have had the piles measured by another company using these pictures so I assume my dataset is good. 75% overlap at 200ft. I also did both headings. Anyway I imported the pictures into WebODM last night using what I assume was out of box settings and it finished this morning. All of that went very smoothly and produced a good map. I went to measure the piles on the 2D map with the volume function, dropping pins around the piles. Once I finished a pile, it says “computing” for less than a minute and then it says “Invalid Task Output (Cannot Find Valid Key)”. I’m guessing it’s user error and something I’m just missing but any help would be greatly appreciated. If any one needs more info, just let me know and bear with me while I do my best to try get it posted.

Thanks!

1 Like

Welcome!

Sorry you’re having trouble.

Could you provide some details about your platform, installation method, and version/build of WebODM?

Correct me if I’m wrong, don’t be concerned about offending me haha I’m a little slow with this. I am using windows 10, 32 gb of ram, 64 bit processor (not sure if that’s all your looking for). I went to WebODM website paid for it and downloaded it through the link that came to email and installed it through the prompts that came up. WebODM 1.9.11 is what it looks like to me. Hopefully that’s what you’re looking for and if not I have no problem getting you some more info. Thanks for the fast reply!

1 Like

Do you happen to know if you’re on Build 41?
image

(That was all excellent information provided above, thank you!)

Yes I just checked and it looks like build 41 to me.

1 Like

Would you be willing to uninstall it, delete the installation directory (C:\WebODM most likely), and re-installing?

I could definitely try to do that. Probably going to be a dumb question but how do I do that?

So, you can start by finding/clicking WebODM in your Start Menu, going to Uninstall, and then going through the uninstall process.

image

image

Then, you can open File Explorer, and navigate to C: by going to This PC on the left panel. You should see a WebODM folder. Click once to select it, then press the delete key and confirm the dialog message.

Then you would just run the installer again to re-install it.

Ok I believe I did that correctly, thank you! Just reinstalled it right now. I reopened the program, should I create the dataset in a different way or just put the pictures in and let it do it’s thing?

1 Like

Try to update (build 42, just pushed it a few minutes ago), which should (hopefully) fix this. :pray:

Not an user error, we’ve recently updated GRASS in WebODM and that has been giving some issues on Windows.

Related: Measurements not completing, stuck on "computing" · Issue #1092 · OpenDroneMap/WebODM · GitHub

1 Like

Thank you very much! I will update and let you guys know how it goes.

2 Likes

I got everything finished and measured another pile. It worked! Thanks for the help guys and fast support!

4 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.