Very High Vertical GCP Error

Hi Everyone,

I am currently having an issue with the vertical accuracy of my GCPs. I processed with full sized images and selected the dsm/dtm option.

Is there anything I can do to reduce this error?

Here are the results for the quality report:

Webodm Logs: Webodm logs -

Images and GCP file Used:

Any help would be greatly appreciated. Thanks

1 Like

What I see is, that I could not find any GCP’s at all, just 3 markers on the ground, but in your list there are more rows than markers. So it is really hard to process the dataset and tell you what’s wrong.
If you are on budget, try making these: DIY Ground Control Points - Learning Area - OpenDroneMap Community (Also forum mods: could you please open that topic, I would like to add some more information)

1 Like

Are you able to post the full log?

If not, do you recall if you adjusted --gps-accuracy any? What is your expected average GPS accuracy for the entire dataset? We currently have that flag default to 10m, so if your data are more accurate than that, you might get an improvement by constraining it to something closer to your mean GPS accuracy.

1 Like

I had 12 markers sprayed on the ground. This normally works just as well as 500mmx500mm GCP panels which I also have, but did not use in this flight.

I processed again and tagged the GCP’s with better vertical accuracy with more images and got a better result. I also set quality to medium.


From these results I thought that maybe I had not tagged enough images, so I reprocessed with more GCP’s tagged for all the GCP’s but some how got a worse result:

1 Like

Can you set quality to high or ultra alongside your adjusted gps-accuracy and your not-fully tagged GCP list?

Not sure what this means, I just select the feature quality in the dropdown list in the settings. I have not touched gps accuracy, I just leave that as default.

1 Like

If you edit the Processing Options for the task, you can expose a lot more features and tune them for your needs:

I have played around with those settings, it does not seem to change anything. We are flying with a Phantom 4 Pro without RTK. But our GCPs are measured with an RTK rover with 3cm vertical accuracy.

Are there any settings that could be changed that suit this setup?


1 Like
--feature-quality ultra
--gps-accuracy 0.6

Something along these lines I think might improve things a bit.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.