Utilising another harddrive on Linux virtual machine


I’ve been trying to search for a solution for this problem on the forum but could not find anything that helped. I have installed WebODM on a linux virtual machine running on our university server. The virtual machine only has 20 GB as its roots drive, yet it has a 1 TB volume attached called “drive.”

I have been trying to launch WebODM using ./webodm.sh start --media-dir …/…/…/drive/

yet when I open the dashboard and go on diagnostics, I still see only remaining space from the 20 GB harddrive. Does anyone know how I can link it to the 1 TB drive?

Many thanks

1 Like


You’ve verified that USB pass-through works and that not only the Linux VM can read/write the volume, but also Docker (assuming you’re using the Docker release)?

Hi again,

I am using it through docker. I can write to the volume in linux, how can i verify docker can read or write to the volume? do i need to mount the volume within docker?

1 Like

I found this post, but this example is using docker on windows and I am not sure how it translates to linux

1 Like

Yes, docker would need to be able to read and write to the drive and have it mounted, probably as a bind mount.

You can try this to store all docker files on the USB drive:

Hi and thanks for a quick response. I tried creating a daemon.json file in /etc/docker/ as I did not have one, and I filled it with
“data-root”: “/drive/data”

then restarted docker. however I get an error that the file cannot be found. Does this look right to you?

1 Like

That sounds like the path to the drive is incorrect, or possibly that docker or your user don’t have access.

Do you have anyone in your University IT who can assist you?


Actually I fixed it using the suggesion here How to specify different root directory for Docker on Linux - #5 by geoma

If this helps with others:

Stop docker
sudo service docker stop

Move old docker over to new drive

cp -r /var/lib/docker /drive/data/docker

Make a config file

sudo nano /etc/docker/daemon.json

Add the path to the new drive

  "data-root": "/drive/data/docker"

Restart docker
sudo service docker start

docker info -f '{{ .DockerRootDir}}'

Then restart the webodm service


Glad you are up and running!

Happy processing!

1 Like

I try create a Pull Request to fix this issue
Please see this link for any code changes

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.