Upside down build

#1

Hello Folks,

OK, I’ve tried everything within my abilities to sort this, but to no avail. So I’m asking for help.

System: i5 4690k, 24GB RAM, Debian Stable, Docker version 18.09.5, build e8ff056dbc, WebODM latest build.

Files are here; https://drive.google.com/drive/folders/1hsXmjl0nyk5nobUW5iuFvKj-ufmAeL9_?usp=sharing

Problem:

With no control points, this small (9 photo) dataset builds perfectly, correctly orientated etc. But (obviously) I have no orthophoto option.

I’ve tried building this data set with GNSS data injected into the EXIF of the images, which unfortunately is worse than the above.

I’ve tried creating GCPs using WebODM, that builds the right way up but locates the build somewhere in the Northern Atlantic for some unknown reason (yes, I was tagging in the right location :D).

I’ve extracted GNSS data from my flight log (checked the flight log on QGIS to confirm in right location) and converted that to WGS84, this has gotten me the closest to a useable product, but it’s still inverted (I’ve had upside down builds, side on builds…).

I read on another thread on here about turning on the fixed camera parameters for builds under 500mx500m, that didn’t work (I don’t use a DJI and the camera is a CHDK hacked canon S110). I also looked at the other “upside down build” thread from Feb but there are no replies. I’ve also checked on GitHub.

Can anyone offer any advice? Build log file is in the linked google folder, along with the GCP file, the images and all of the outputs.

Thanks in advance,

Leon

#2

did you, try, to reverse the coordinates you injected in the exif information?