Uploading to Cloud hosted version

I have a cloud hosted version that I only use to upload the zipped “all Files” so that I can share the results with people. It has been working pretty well.
However today every time I try to upload a zipped file I get an error that it couldn’t load the file right away after it complete the upload. Approx 275mb.
I do change the name of the file from all.zip. Does that matter ? I have even added memory to the VM instance in google but that didn’t fix it.

1 Like

I tried uploading all.zip and it still didn’t work.

1 Like

Name doesn’t matter when importing the all.zip, provided you don’t have any non-ASCII characters.

Are you sure your Cloud hosted version has sufficient space and your connection is stable?

Thats what i thought it was initially and i added more memory. I will take a closer look tomorrow.
Im using starlink…this is the first time using starlink fkr this, but no other uploads have been a problem.

1 Like

I have no recommendations to increase my memory on the dashboard.
Now it stops uploading before 10% is even done.

1 Like

Can you attempt via another ISP?

I uploaded it to my google drive thinking it would load from there but nope. It says to check my internet connection ?

1 Like

Yeah, I’m wondering if StarLink isn’t hassling you. Can you do this from another connection?

not really…that’s why I uploaded it to my google drive. Might it work from dropbox or some other online repository ?

1 Like

We don’t have a means to sideload all.zip data from Cloud Service providers, so not at this juncture, no.

Ah, I was trying to use the “Import From URL” button.
Im going to see if a can get a decent wifi from my cell and try that.

1 Like

Google Drive doesn’t have direct/deep linking, and the permissions models it uses confounds things further. You’d likely have better luck if you could stick it on a regular webserver or something, or another provider that allows direct/deep linking…

Looks like we can do it via DroneDB.app!

Upload your all.zip(s), select one, right-click the download icon on the top-right, Copy Link, and use that to sideload!

“Cannot import from URL. Check your internet connection.”
This would piss off the average guy.
I’m guessing you tried it on a hosted version that you have access to, so I’m wondering why my version isn’t working right. I recently did the update up to Step 6 …

  1. Launch a Google Cloud instance of Ubuntu 18.0 LTS.
  2. Open the SSH terminal - Google offers SSH via the website.
  3. Run sudo apt-get update
  4. Run sudo apt-get upgrade
  5. Run sudo apt-get install docker-compose
  6. Run sudo apt-get install python-pip
  7. Run git clone GitHub - OpenDroneMap/WebODM: User-friendly, commercial-grade software for processing aerial imagery. 🛩 --config core.autocrlf=input --depth 1

I didn’t do step 7 because it thought it would delete everything, however I’m starting to think that I might have to delete this whole VM instance and start all over.

1 Like

No, nothing fancy here.

Just Dockerized WebODM importing from public DroneDB hub.

Here’s a video of my workflow:

Yup…exactly what I’m doing.
Right after pasting the link…
https://hub.dronedb.app/orgs/bobstaff/ds/nmpkmpkvq2zzqn0u/download/Mohawk%20Heights%20Apr2022_1.zip

…and clicking Import, I immediatly get “Cannot import from URL. Check your internet connection.”

1 Like

I’m wondering if Google is enforcing some CORS security, and it seems like they are:

Great…more stuff I have to learn a bout. Odd that I have been able to do this before with no problems.

1 Like

So I deleted the VM in google and reinstalled everything.
Works like a charm…except that now I have to rebiuild the site and add all the acounts and tasks back in.
I appreciate your help !

2 Likes

So after all that now when I click on the ortho map to do measurments, as soon as I click on a spot, the map shifts off to the side. It doesn’t do it on the 3d map.
I tried different zip file and same thing. This function was working fine before all this started happening.
http://34.130.65.249:8000/public/task/6b89eb6e-9de2-4fe1-bf31-485be0c0b90d/map/

1 Like

It took a long while, but it eventually loaded in with some errors in the Console: