Understanding the Node-Micmac

Hi All,

Im on Ubuntu 18.04 Google cloud 8 cores 30GB Ram 120GB HDD

I managed to get the node-micmac installed. Now I see it in the processing nodes with the port 3000.

It said node-micmac is inactive. How should I run it. I tried to start the micmac but never get connected to the port 3000 (all ports in firewall were config).

Have seen the command ./webodm.sh restart --with-micmac somewhere. Is this the way to activate the node-micmac in webodm inteface?


Hello, I hope you are well

I am new to writing on the forum, although I have been an active reader for some time.

I have worked webodm on Docker for Windows and specifically I work more with the NodeMicMac module. To connect, (taking into account that you already have the module installed) I just execute the command “./webodm.sh start --with-micmac” and then in the browser (chrome in my case), I enter the link "http: / / localhost: 8000 "-Works without problem-.

Hope it helps you


William from Colombia

1 Like

Hi tatowem,

when you use NodeMicMac do you have issues with the 3D model displaying in the WebODM interface? I can process with the NodeMicMac but the 3D view does not open. when i process with the NodeODM it displays fine, but not at the same quality as those which process with NodeMicMac.

I had the same issues, I did a fresh reinstall which fixed that problem.

Hi @Richardsonmapper

Yes, I have had the problem you mention. The solution is to reinstall everything from scratch?

Thank you, I appreciate your answers.


Hi Tatowem,

Yes reinstalling from scratch fixed the NodeMicMac so that I could process image sets on via that node. However after reinstalling WebODM the 3D model does not display in the 3D viewer so I’m currently trying to find out who knows how to resolve this issue.


I’ve the same behavior.
My dataset coming from a dji spark, the gps data have a limited accuracy:

Exif.GPSInfo.GPSLatitudeRef                  Ascii       2  South
Exif.GPSInfo.GPSLatitude                     Rational    3  19deg 36' 55"
Exif.GPSInfo.GPSLongitudeRef                 Ascii       2  West
Exif.GPSInfo.GPSLongitude                    Rational    3  43deg 27' 26"

Could that be a part of the problem ?

No I’m sure that’s not the problem, I’m using a mavic. It soemthing wrong with the node I think.

Currently NodeMicMac docker image is broken, so it can not build point cloud.
NodeMicMac issue
Either you have to build yourself from repo or you have to ask the owner to rebuilding docker image.
And NodeMicMac does not provide textured 3D model.
It just give you coloured point cloud.

1 Like

Thsk you @rumenchooo, it all makes sense now. Thanks a million!