Unable to push changes from dev mode to production mode

Hi everyone,

I have made some customization towards WebODM --dev mode. However, when I tried to push these changes to production mode, they are not adopted at all. Does anyone know what problems or tools it may relate to (docker, server etc.)? How can I possibly do to resolve this issue? Thanks.

Hey @harry.shen, I’ve just added this that explains it: WebODM/_fordevelopers.md at master · OpenDroneMap/WebODM · GitHub

3 Likes

Thanks for answering my question. I tried rebuilding the docker image with the command:
docker build -t opendronemap/webodm_webapp .

but I got the error message like below:

ERROR in Entry module not found: Error: Can't resolve './src' in '/webodm' The command '/bin/sh -c npm install --quiet -g webpack@4.16.5 && npm install --quiet -g webpack-cli@4.2.0 && npm install --quiet && webpack --mode production' returned a non-zero code: 1

I tried manually installed webpack and webpack-cli globally but this error still happened anyway.

Make sure you are running the command from the WebODM directory.

1 Like