Unable to find image 'opendronemap/opendronemap:latest' locally

After I use the code:
(base) notebook:_open_drone_test tiagootani$ docker run -it --rm -v “$(pwd)/images:/code/images” -v “$(pwd)/odm_orthophoto:/code/odm_orthophoto” -v “$(pwd)/odm_texturing:/code/odm_texturing” opendronemap/opendronemap

Unable to find image ‘opendronemap/opendronemap:latest’ locally
docker: Error response from daemon: manifest for opendronemap/opendronemap:latest not found: manifest unknown: manifest unknown.
See ‘docker run --help’.

1 Like

Try the image opendronemap\odm instead.

1 Like

It works with opendronemap/odm,
but now,
it appears:
“Not enough supported images in /code/images”

What do you get if you run
ls $(pwd)/images

When I just write ls
it appears all my images,
but when I put ls $(pwd)/images,
nothing appears
and when I write just pwd:

Ahh, type cd .. first to go up one level. Then run.

I did it,
Thanks a lot,
I cannot explain how happy I am,

Haha! Excellent! Good luck and let us know how it goes.

Now, It ran,
But I dont know where the files are now.
It just created one empty file “odm_orthophoto”
and 3 files within the “odm_texturing”:

  • odm_textured_model_data_costs.spt
  • odm_textured_model_labeling.vec
  • odm_textured_model.conf
  • tmp with all my images but in png format

I ran it again,
Now it generated.
Thanks again!

When I run $(pwd)/images, It lists all the jpg images inside the images folder. But, still ODM cant find enough supported images.
I am running ODM in Windows 10 using Windows Subsystem Linux. Docker image I am using is Opendronemap/ODM.
Can you guide me? Thanks in advance