Unable to bring processing node online

hello, I am a new user that got webodm a while ago, when I got it I tried to import photos and it gave me the error “There are no usable processing nodes. Make sure that at least one processing node is reachable and that you have granted the current user sufficient permissions to view the processing node (by going to Administration – Processing Nodes – Select Node – Object Permissions – Add User/Group and check CAN VIEW PROCESSING NODE). If you are bringing a node back online, it will take about 30 seconds for WebODM to recognize it.” I checked the proccesing node and it said it “seems to be offline” so I tried to create my own with no more succes, it gives me the same error, any help to fix this would be appreciated, thanks!

1 Like

Welcome!

Could you please provide a bit more detail about the platform you’re running on, the method of installation, and what version of WebODM you’re currently working with?

I’m using a mac on mac os 11.6 and Safari 15, WebODM should be on the latest version as I got it 5 days ago, I have very limited command-line knowledge but enough to install WebODM manually

1 Like

Would this happen to be an ARM/Apple M1 powered device?

If so, there was a bug in our Docker images for the M1, and they are being rebuilt and should be available later tonight or early tomorrow.

no this is a 2015 mac

Have you tried rebooting the machine and re-getting the latest docker images?

how do I get docker images

How did you get them initially?

Are you using the WebODM Manager for MacOS by UAV4Geo, or did you install manually?

I installed it manually I have docker and I click on images and press run, is that what you mean by regretting them?

Try this guide:
How To Update Docker Image And Container {3 Easy Steps} (phoenixnap.com)

Screen Shot 2021-10-20 at 1.44.24 PM

1 Like

Yep, looks like maybe updating would be beneficial for you:
image

So, you could

docker pull opendronemap/....

for each image and see if you get updated further.

k I updated all images and the processing node is still offline

https://docs.opendronemap.org/installation/#id1

Following these steps, have you verified everything (hardware virtualization suppport), and issued a stop/start?

hey, thanks for trying to help, I decided to just go ahead and get the installer, everything is working well now. thanks!

1 Like

The Easy-Installer is aptly named, eh? Haha.

Glad you’re up and running, I apologize I wasn’t able to assist you promptly, and welcome and we hope to see you post some cool stuff when you feel like it!

yes thanks for the help!

1 Like